weixin_39874809
2020-12-08 18:04 阅读 3

ARAnalytics/Flurry has wrong analytics version

Podfile tries to activate 'ARAnalytics/Flurry (= 2.3.3)', but already activated version '2.4.0' by Podfile and ARAnalytics/Mixpanel (2.4.0).

In my Podfile:


pod 'ARAnalytics/Mixpanel'
pod 'ARAnalytics/Flurry'
pod 'ARAnalytics/GoogleAnalytics'

该提问来源于开源项目:orta/ARAnalytics

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • weixin_39874809 weixin_39874809 2020-12-08 18:04

    fwiw changing my Podfile to the following corrects the problem:

    
    pod 'ARAnalytics/Mixpanel', '~> 2.4.0'
    pod 'ARAnalytics/Flurry', '~> 2.4.0'
    pod 'ARAnalytics/GoogleAnalytics', '~> 2.4.0'
    
    点赞 评论 复制链接分享
  • weixin_39568233 weixin_39568233 2020-12-08 18:04

    Hrm, I can see why this is happening now, but I think it's a CocoaPods bug, thanks for the work-around, I'll create an issue on the project.

    点赞 评论 复制链接分享
  • weixin_39568233 weixin_39568233 2020-12-08 18:04

    think this is fixed in 0.29.

    点赞 评论 复制链接分享
  • weixin_39568233 weixin_39568233 2020-12-08 18:04

    I don't think I've seen this in a while. Closing, open to being re-opened.

    点赞 评论 复制链接分享

相关推荐