2 qq 24623079 qq_24623079 于 2017.01.08 10:19 提问

python升级后,pip不好用了。然后打算用升级后的python重装pip 结果报错,求助! 5C

[root@iZ5qb441i7rtx5Z pip-8.1.2]# /usr/local/python27/bin/python setup.py install
Traceback (most recent call last):
File "setup.py", line 6, in
from setuptools import setup, find_packages
ImportError: No module named setuptools

4个回答

devmiao
devmiao   Ds   Rxr 2017.01.08 10:47
oyljerry
oyljerry   Ds   Rxr 2017.01.08 13:29

http://blog.sina.com.cn/s/blog_3fe961ae0100zgav.html

就是你的环境没有setuptools,所以需要xiananzhsetuptools!然后才可以通过它来安装其他的setup.psetup.py

qq_37284837
qq_37284837   2017.01.08 13:44

TFcjjchhjkkkjgfyuTdghydg

Mrtwofly
Mrtwofly   2017.01.08 20:49
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
python升级后 pip报错
ubuntu自带的python升级后,原来的pip不能直接用了,报错。 报错信息 root@konghao:/home/konghao/Python-2.7.13# pip Traceback (most recent call last): File "/usr/bin/pip", line 5, in from pkg_resources import load_en
python升级引起的pip执行错误
centos6.x默认安装的python为2.6版本,今天换成了3.5版本 这里不再讲如何升级python版本 在安装完新的版本后,之前安装的插件都不能使用了,再用pip进行安装提示已经安装过,但是运行程序依旧在import出报错。 执行升级命令 python -m pip install -U pip 升级成功,但依旧在运行程序时报找不到import的插件 于是用python
Ubuntu pip升级后无法使用pip
Pre-steps: 1. 通过命令升级过pip和setuptools ``` pip install --upgrade pip pip install --upgrade setuptools ``` 2.此前移除了python2.x和链接了python3.x 3. 卸载了pip,只使用pip3 Result: 在经过上面的操作后突然出现了下面几个问题: a. termina...
Centos 升级到python3后pip 无法使用
一. 问题[root@localhost local]# pip -bash: pip: command not found 二. 系统环境 Centos 6.6 Python 3.5.2 三. 解决方法设置软连接.1.查找pip所在位置[root@xxx local]# find / -name "pip" /Python-3.5.2/Tools/msi/pip /usr/bin/pip /usr
python从2.6升级到3.6后安装pip报错SSL模块不存在
python从2.6升级到3.6后安装pip报错SSL模块不存在python get-pip.py 报错:pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.解决办法:网上介绍的一种办法,对3.6.5版本而言,无此参数,无效./configu...
Windows下python pip升级失败的解决方案
Windows下升级pip推荐的方式为: $ python -m pip install --upgrade pip 这样操作却往往会出现下面的错误: Exception: Traceback (most recent call last): File "D:\Kangbeibei\python_project\datamining-learning\decision_tree\ve...
Ubuntu升级到18.04之后pip无法使用的问题
down vote The bug is found in pip 10.0.0.In linux you need to modify file: /usr/bin/pip from:from pip import main if __name__ == '__main__': sys.exit(main()) to ...
pip升级报错总结
1 权限问题 C:\Users\ljf>pip install xlwt Exception: Traceback (most recent call last): File "c:\program files\python35\lib\site-packages\pip\basecommand.py", line 21 1, in main status = self.run
python 升级 pip
python -m pip install --upgrade pip
pip升级后遇到的错误
pip升级到10之后出现错误,解决方法卸载原有的pip  apt-get remove python-pipeasy_install -U pip原理未知,留个坑回头踩