2 qq 35277299 qq_35277299 于 2017.01.11 21:37 提问

用户代码未处理SqlException

哪位前辈可以帮我解决这个问题呀图片

1个回答

caozhy
caozhy   Ds   Rxr 2017.01.11 23:55

sql server配置问题,检查连接字符串,是否启用tcp协议,防火墙和远程连接启用

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
用户登录失败--未处理SqlException
前段时间,小编在敲三层的时候,遇到了以下图片中的错误,小编成功将它“拿下”了,怎么解决的呢,请继续向下看。   错误原因: 连接数据库的语句中有错误--符号写错了; 正确写法:  public static string ConnString = "Server=.;Database =Login;User ID=sa;Password=123456";
关于SubSonic3.0生成的表名自动加复数(s)的“用户代码未处理SqlException,对象名'xxxs'无效”异常处理
使用SubSonic3.0模版生成时,同2.2版本一样,都会自动在一些类似数据库要用到的关键后面加要s(复数),这里也是3.0的一个小Bug,在查询时由于插件并没有完全的去掉s,所以会产生“用户代码未处理SqlException,对象名'xxxs'无效”异常,无法对加了复数的表进行查询 2.2处理就会简单,直接在config(配置文件)里配置SubSonicService标签,在该标签里的ad
用户代码未处理
在看北大青鸟的教程,按照教程调试代码的时候发现一个错误,怎么也找不到原因,暂且记录....用户代码未处理 System.Data.SqlClient.SqlException 全文代码: using System;using System.Data;using System.Configuration;using System.Collections;using System.
用户代码未处理MetadataException
最近在用EF搭框架的过程中,遇到了很多问题,大部分都是出现在配置文件中,比如说下面这个问题:                                                                       问题描述:error 0152: No Entity Framework provider found for the ADO.NET provider wi
用户代码未处理——存储区更新问题
背景   上一次做项目的时候落下的问题,一直都想总结,但是一直也没有总结。现在该做个了断。跟bug说再见吧。 错误   废话不多说,直接上图片    错误原因分析:   在本项目中出现这个错误的原因是,我在界client端的.chtml视图页中传递的参数少了一个,所以如果是进行数据库的插入操作的时候,因为该字段值不能为空。但是前段并没有传输过来数据,所以就导致我们无法往数据库中存入数据
C#窗体连接数据库出现未处理SqlException解决办法
将界面的名称改成当前包含用户名和密码的那张数据表的名称即可对警告信息进行处理,一定要保证数据表里面的用户名及密码的信息保持一致,这样就可以成功连接数据库并且不再出现警告信息
用户代码未处理 UpdateException
无法更新 EntitySet“Project_project”,因为它有一个 DefiningQuery,而 元素中没有支持当前操作的 元素。百思不得其解释,最后发现  1:实体中的表必须有主键(这里指示T_User表中必须有主键),如果没有,会有这样的提示  2:主键设置好后,运行还是会出现类似问题,那就一个郁闷        1):方法一先从EF中删除刚设置主键的模型,然后再重新添加到
未处理 System.Data.SqlClient.SqlException
在建立与服务器的连接时出错。在连接到 SQL Server 2005 时,在默认的设置下 SQL Server 不允许进行远程连接可能会导致此失败。 (provider: 命名管道提供程序, error: 40 - 无法打开到 SQL Server 的连接) 未处理 System.Data.SqlClient.SqlException  Message="在建立与服务器的连接时出错。在连接到 SQ
用户代码未处理 JsonSerializationExection 之解决方法
今天在调试一个OA项目的时候,刚用T4模板加完实体类,在登录测试的时候就出现这个问题, 实在头疼,多方查找之下才发现原来是我序列化得时候,没有对导航属性就行处理,问题的原因在于导航属性中的实体类会导致无限的死循环递归调用,进而导致这个异常出现,解决的办法就是把这些导航属性在序列化得时候忽略掉就可以了如下图就完美解决了。。。。
#c##用户代码未处理ArgumentNullException
问题解决这个问题只要是我们所使用的是是NULL,空的。 这里则是composite[“title”]为NULL。 回头查了下是,我定义的时候打多了一个”i”,写成了”composite[titile]”,因此composite[“title”]是NULL的。 找了很久才发现是一个字母的问题,无奈了。