weixin_39564187
weixin_39564187
2020-12-08 18:28

Backup schedule creates multiple backup when schedule runs

Background (please complete the following information): * Panel : Panel * Version of Panel: v1.0.3 * Server's OS: Ubuntu 20.04 * Your Computer's OS & Browser: Mircosoft Windows 10 Pro - 64bit - Version : 2004 | Browser : Chrome

Describe the bug When the schedule runs for backup , it creates multiple backup instead of creating 1 with just few seconds to an hour difference.

To Reproduce Steps to reproduce the behavior: 1. Go to 'Schedule' 2. Click on 'Create Schedule' 3. Cronjob syntax * /12 * * 4. Click 'Create schedule' 5. Select the Schedule and select 'New Task' Action - Create Backup Time Offset - 0 Ignored Files - /plugins/dynmap 6. Click 'Create Task' 7. Wait for schedule to run 8. Go to backups to find multiple backup run within given schedule

Expected behavior Create single backup when the scheduled backup cronjob runs

Troubleshooting done 1. Tried some other task (tps command with 5 minutes interval) - works without any issues | No multiple command schedule 2. Tries different server - No luck | Same issue persists 3. Restarted wings - No luck 4. Restarts VPS - No luck

Screenshots Multiple Backup created Schedule Working TPS check cronjob

该提问来源于开源项目:pterodactyl/panel

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39841572 weixin_39841572 4月前

    There is not enough information here for me to reproduce this issue or put time into digging into it more. Please confirm what the listed next_run_at time for that schedule is. Otherwise, I'm just going to write it off as a fluke.

    I say this only because I'm not about to spend days trying to debug a schedule that only runs every 12 hours.

    点赞 评论 复制链接分享
  • weixin_39564187 weixin_39564187 4月前

    I get it, tried 5 minutes backup too Still the same issue. Only the backup cronjob does this issue. Normal command cron doesnt return this issue.

    Let know how to get the next_run_at , so i can get the log to work with

    点赞 评论 复制链接分享
  • weixin_39841572 weixin_39841572 4月前

    I am unable to reproduce this, other than my timezones being a little funky from DST which was fixed with php artisan queue:restart.

    I've tried both every minute and every 5 making a backup with an excluded folder, no issues.

    点赞 评论 复制链接分享
  • weixin_39564187 weixin_39564187 4月前

    php artisan queue:restart and changing certbot run time fixed this issue. Found certbot renew running just few seconds after backup cron running. Changed backup schedule and changed certbot renew and restarted queue seems to fix it.

    Certbot renewal has restart wings command in it. No idea how the above change fixed it though. No i have only 1 backup created when backup schedule runs

    点赞 评论 复制链接分享

相关推荐