编程介的小学生 2017-02-13 01:38 采纳率: 20.5%
浏览 773
已采纳

The Game of 31

Problem Description
The game of 31 was a favourite of con artists who rode the railroads in days of yore. The game is played with a deck of 24 cards: four labelled each of 1, 2, 3, 4, 5, 6. The cards in the deck are visible to both players, who alternately withdraw one card from the deck and place it on a pile. The object of the game is to be the last player to lay a card such that the sum of the cards in the pile does not exceed 31. Your task is to determine the eventual winner of a partially played game, assuming each player plays the remainder of the game using a perfect strategy.
For example, in the following game player B wins:
Player A plays 3
Player B plays 5
Player A plays 6
Player B plays 6
Player A plays 5
Player B plays 6

Input
The input will consist of several lines; each line consists of a sequence of zero or more digits representing a partially completed game. The first digit is player A's move; the second player B's move; and so on. You are to complete the game using a perfect strategy for both players and to determine who wins.

Output
For each game, print a line consisting of the input, followed by a space, followed by A or B to indicate the eventual winner of the game.

Sample Input
356656
35665
3566
111126666
552525

Sample Output
356656 B
35665 B
3566 A
111126666 A
552525 A

  • 写回答

2条回答

  • devmiao 2017-02-13 18:22
    关注
     #include<iostream>
    #include<cstdlib>
    #include<stdio.h>
    #include<string.h>
    #include<string.h>
    #include<memory.h>
    using namespace std;
    int sg[50];
    int num[7];
    bool dfs(int sum)
    {
        if(sum>=31) return 0;
        for(int i=1;i<=6;i++)
        {
            if(num[i]&&sum+i<=31)
            {
                --num[i];
                if(dfs(sum+i)==0) {++num[i];return 1;}
                 ++num[i];//回溯
            }
        }
        return 0;
    }
    int main()
    {
        char str[35];
        while(scanf("%s",str)!=EOF)
        {
            int sum=0;
            int l=strlen(str);
            for(int i=1;i<=6;i++)
            num[i]=4;
            for(int i=0;i<l;i++)
            {
                sum+=str[i]-'0';
                num[str[i]-'0']--;
            }
            if(sum>=31)
            {
                printf("%s ",str);
                if(l&1) puts("A");
                else puts("B");
                continue;
            }
            printf("%s ",str);
            if(dfs(sum))
            {
                if(l&1)  puts("B");
                else puts("A");
            }
            else
            {
             if(l&1)  puts("A");
             else puts("B");
           }
        }
    }
    /*
    356656
    35665
    3566
    111126666
    552525
    */
    
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 file converter 转换格式失败 报错 Error marking filters as finished,如何解决?
  • ¥15 ubuntu系统下挂载磁盘上执行./提示权限不够
  • ¥15 Arcgis相交分析无法绘制一个或多个图形
  • ¥15 关于#r语言#的问题:差异分析前数据准备,报错Error in data[, sampleName1] : subscript out of bounds请问怎么解决呀以下是全部代码:
  • ¥15 seatunnel-web使用SQL组件时候后台报错,无法找到表格
  • ¥15 fpga自动售货机数码管(相关搜索:数字时钟)
  • ¥15 用前端向数据库插入数据,通过debug发现数据能走到后端,但是放行之后就会提示错误
  • ¥30 3天&7天&&15天&销量如何统计同一行
  • ¥30 帮我写一段可以读取LD2450数据并计算距离的Arduino代码
  • ¥15 飞机曲面部件如机翼,壁板等具体的孔位模型