openwrt配置双wan口,配置后网口不通

linux kernel 3.3.8,CPU qca9531(集成switch、phy,有GMAC0和GMAC1)。WAN口物理层接在GMAC0,GMAC1上接了交换芯片,现在想从GMAC1上虚拟出一个WAN口。查看openwrt官网http://wiki.openwrt.org/doc/uci/network/switch进行修改原来的/etc/config/network文件后网口就不通了,是不是有哪些背景知识我没有了解到?原来的文件如图片所示,我是做底层芯片驱动的,对openwrt这些配置是小白,请帮忙看下修改后的文件,多谢!如下:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'config
interface 'lan'
option ifname 'eth1.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
config interface 'wan2'
option ifname 'eth1.3'
option proto 'dhcp'
option pingstatus '0'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
option pingstatus '0'
config interface 'guest'
option ifname 'eth1.2'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
config switch
option name 'eth1'
config switch_vlan
option enable_vlan '1''
config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 1 2 4'
config switch_vlan
option device 'eth1'
option vlan '2'
config switch_vlan
option device 'eth1'
option vlan '3'
option ports '0 3'
图片说明

1个回答

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐