qq_35881717
我叫jc
2017-03-03 09:36
采纳率: 100%
浏览 4.6k
已采纳

Eclipse测试出现failure问题

今天想学习下JDBC,结果run as出现错误,望有大神解决
代码很简单如下:
public class jdbc {

@Test
public void test() {
    System.out.println("sssadasda");
}
}

错误信息:
  java.lang.AssertionError: Not yet implemented
at org.junit.Assert.fail(Assert.java:88)
at ainiyongbubian.jdbc.test(jdbc.java:11)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

······
图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • qq_35881717
    我叫jc 2017-03-04 05:31
    已采纳

    图片说明 发现JRE System Library 的不同了吗? jdk1.8._31是可以运行成功的
    问题解决了
    太坑了。。。以前测试都可以的,昨天代码写好也找不出错误来,发现了运行failure。
    最坑的是在你导入的确实是jdk1.8._31不是javasSE_1.8,运行还是错误,网上也找不到答案,有关junit的资料确实比较少

    重新建个新的或者导入jdk1.8._31,然后需要重启eclipse,搞定!

    点赞 1 评论
  • qq_16801241
    qq_16801241 2017-03-03 09:44
    点赞 评论
  • qq455276333

    请把代码贴出来

    点赞 评论

相关推荐