a1021508536
花重锦官城
采纳率25%
2017-03-07 08:12

android studio 5.0以下编译不成功

android studio classpath 'com.android.tools.build:gradle:2.0.0' 这能编译成功5.0以上的,以下的都编译不成功
bulid。gradle:
compileSdkVersion 23
buildToolsVersion "23.0.1"
defaultConfig {
minSdkVersion 14
targetSdkVersion 23
versionCode 1
versionName "1"
}
如果将.build:gradle:2.0.0 改成1.2.3的话连5.0都编译不成功了

编译失败的原因是导包重复
Error:Execution failed for task ':app:transformClassesWithDexForDebug'.

com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'D:\Program Files\Java\jdk1.7\bin\java.exe'' finished with non-zero exit value 2
跪求大牛帮忙解答。。。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

3条回答

  • a1021508536 花重锦官城 4年前

    调好了,原来是友盟和微信支付的jar包有重复的内容,所以报了错,但是5.0以上没报错真是奇怪

    点赞 评论 复制链接分享
  • qq_33700351 纯洁小码农_z 4年前

    猜测应该是版本问题,把AS升级到最新版,并下载24或者25的sdk,把build里的那些sdk版本都改试试,当然,如果用24及以上的sdk,JDK对应要改成1.8

    点赞 评论 复制链接分享
  • as_csdn 代码的灵魂是bug! 4年前

    将jdk的版本改成1.8试试

    点赞 评论 复制链接分享

相关推荐