qq_37147202
2017-03-10 03:38
采纳率: 100%
浏览 1.1k
已采纳

Spring的appincationcontext和spring JAR包的版本有关吗?

我的Spring jar包开始用的3.0版本,开自动扫描会说我的JDK1.8版本不能匹配,然后换了Spring 4.0的版J本JAR包,但是还是不行,是因为我的applicationcontext也要换吗
错误的大致代码如下 求大神
exception
javax.servlet.ServletException: Servlet.init() for servlet servletSpring threw exception

root cause
org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [applicationContext.xml]; nested exception is java.lang.NoClassDefFoundError: org/springframework/aop/TargetSource

root cause
java.lang.NoClassDefFoundError: org/springframework/aop/TargetSource

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

3条回答 默认 最新

相关推荐 更多相似问题