橘猫掸子
2017-03-19 10:28
采纳率: 40%
浏览 1.2k
已采纳

关于javaSSM框架的问题,新手求教

为什么我的controller类里面要@controller这个注解会报错图片说明

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

10条回答 默认 最新

  • 夜半无声 2017-03-22 06:38
    已采纳

    图片说明

    引入相对应的包;import org.springframework.stereotype.Controller;

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • 仲达先生 2017-03-19 10:55

    是不是没有包?或者没倒入?

    如果有包、你指着它,把erro info 贴出来。

    评论
    解决 无用
    打赏 举报
  • syhleo 2017-03-19 11:13

    没有导入相应的jar包!

    评论
    解决 无用
    打赏 举报
  • 皎月明离人泪 2017-03-19 11:43

    你都没有导入它的包,肯定报错

    评论
    解决 无用
    打赏 举报
  • Seraphim_Fly 2017-03-19 12:00

    有maven吗 把包导一下

    评论
    解决 无用
    打赏 举报
  • eff666 2017-03-19 12:04

    没有导入jar包,把jar包导入就好了

    评论
    解决 无用
    打赏 举报
  • KnowsHow 2017-03-19 16:16

    crtl+shift+o

    评论
    解决 无用
    打赏 举报
  • ?????| 2017-03-20 03:43

    SSM? 用的是spring +springmvc +mybatis 还是struts +spring +mybatis ? 看看你都有哪些表,把包截图贴上来。

    评论
    解决 无用
    打赏 举报
  • qq_35919714 2017-03-20 06:09

    在jar包都正确导入的情况下,可能为jdk版本过高的原因,试试1.6的

    评论
    解决 无用
    打赏 举报
  • 凌岩歌-贰拾肆 2017-03-20 11:02

    是不是没有包?或者没导入

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题