android项目导入问题,新手小白求大虾帮忙

项目启动报[2017-03-23 10:14:01 - main] ------------------------------
[2017-03-23 10:14:01 - main] Android Launch!
[2017-03-23 10:14:01 - main] adb is running normally.
[2017-03-23 10:14:01 - main] No Launcher activity found!
[2017-03-23 10:14:01 - main] The launch will only sync the application package on the device!
[2017-03-23 10:14:01 - main] Performing sync
[2017-03-23 10:14:01 - main] Automatic Target Mode: Preferred AVD 'android4.4' is available on emulator 'emulator-5554'
[2017-03-23 10:14:01 - main] WARNING: Application does not specify an API level requirement!
[2017-03-23 10:14:01 - main] Device API version is 19 (Android 4.4.2)
[2017-03-23 10:14:04 - main] Application already deployed. No need to reinstall.
[2017-03-23 10:14:04 - main] \main\bin\main.apk installed on device
[2017-03-23 10:14:04 - main] Done!
安卓虚拟机上也没有任何反应

2个回答

创建项目时AndroidManifest.xml文件中没有指定Min SDK Version

  解决办法:修改AndroidManifest.xml文件,在 之间加入如下代码: 例如

android:minSdkVersion="8"
android:targetSdkVersion="21"/>
  使用android:minSdkVersion指明运行这个Android应用的最低SDK版本,minSdkVersion="8"表示使用的Android 2.2的版本,android:targetSdkVersion指明编译这个Android应用的SDK版本,targetSdkVersion="21"表示使用的Android 5.0.1的版本。

你尝试吧虚拟机重新启动一下,或者直接再付运行一次看看可不可以

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问