weixin_39775976
weixin_39775976
2020-12-08 21:18

AppImage does not run on Ubuntu 16.04.

Does not run on Ubuntu 16.04. The ingredients inside this AppImage are from a too new system:

/run/firejail/appimage/.appimage-9121/AppRun: /lib/x86_64-linux-gnu/libgcc_s.so.1: versionGCC_7.0.0' not found (required by /run/firejail/appimage/.appimage-9121/usr/bin/../lib/libwebkit2gtk-4.0.so.37)`

Please compile on Ubuntu xenial or older so that the AppImage will run on all still-supported versions of Ubuntu, not just the latest.

Reference: https://github.com/AppImage/appimage.github.io/pull/1987

该提问来源于开源项目:rekon-oss/portfall

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39955149 weixin_39955149 5月前

    Hey thanks for submitting Portfall to AppImageHub!

    I made a change to the ci pipeline here https://github.com/rekon-oss/portfall/compare/v0.7.4...v0.8.1 but found that it was then breaking for me on my 18.04 based OS so i have reverted in v0.8.2. If you could check if https://github.com/rekon-oss/portfall/releases/download/v0.8.1/Portfall-x86_64.AppImage works on ubuntu 16.04 then I could create a separate binary for 16.04 although i'm not sure whether that'd work for AppImageHub since presumably it expects one binary only.

    Any ideas?

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 5月前

    Thanks . Always great to see ApImages for Linux apps. Why do you think you'd need a "separate binary for 16.04", why not make it the only one? Binaries compiled on older distributions should always run on newer ones, otherwise we have a bug...

    点赞 评论 复制链接分享
  • weixin_39697143 weixin_39697143 5月前

    Ran into this with an ubuntu 18.04. Is there any info that would help resolve this issue?

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 5月前

    Is there any info that would help resolve this issue?

    What happens if you run an AppImage created on 16.04 on a 18.04 system? Does the command line show any errors?

    点赞 评论 复制链接分享