编程介的小学生 2017-05-30 05:07 采纳率: 20.5%
浏览 842
已采纳

Has the sum exceeded

Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.

Sample Input
32
100 100

Sample Output
WaHaHa

  • 写回答

2条回答 默认 最新

  • SuperKilling 2017-05-30 08:32
    关注

    #include "stdafx.h"
    #include "iostream"

    using namespace std;

    int main()
    {
    int k = 0;
    long int A = 0, B = 0;
    double Sum = 0.0;

    //input k , A and B
    cin >> k;
    cin >> A;
    cin >> B;

    if (k < 2 || k > 64)
    {
        cout << "k is not in [2, 64]"<<endl;
        return   0;
    }
    
    Sum = (double)A + (double)B;
    
    if (Sum > pow(2, k) )
    {
        cout << "yes" << endl;
        return   0;
    }
    else
    {
        cout << "WaHaHa" << endl;
        return   0;
    }
    
    return   0;
    

    }

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 这是哪个作者做的宝宝起名网站
  • ¥60 版本过低apk如何修改可以兼容新的安卓系统
  • ¥25 由IPR导致的DRIVER_POWER_STATE_FAILURE蓝屏
  • ¥50 有数据,怎么建立模型求影响全要素生产率的因素
  • ¥50 有数据,怎么用matlab求全要素生产率
  • ¥15 TI的insta-spin例程
  • ¥15 完成下列问题完成下列问题
  • ¥15 C#算法问题, 不知道怎么处理这个数据的转换
  • ¥15 YoloV5 第三方库的版本对照问题
  • ¥15 请完成下列相关问题!