u013465293
e206842
采纳率0%
2017-06-04 13:47 阅读 5.9k

centos7安装rabbitmq依赖问题,求解。

--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0(WXU_2.8.10)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_xrc-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_html-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_adv-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu_xml-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_gl-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_stc-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
---> 软件包 erlang-xmerl.x86_64.0.20.0rc1-3.el7.centos 将被 安装
--> 正在检查事务
---> 软件包 erlang-wx.x86_64.0.20.0rc1-3.el7.centos 将被 安装
--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0(WXU_2.8.10)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_xrc-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_html-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_adv-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu_xml-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_gl-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_baseu-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_stc-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_aui-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
--> 正在处理依赖关系 libwx_gtk2u_core-2.8.so.0()(64bit),它被软件包 erlang-wx-20.0rc1-3.el7.centos.x86_64 需要
---> 软件包 unixODBC.x86_64.0.2.3.1-11.el7 将被 安装
--> 解决依赖关系完成
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_gl-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_core-2.8.so.0(WXU_2.8.10)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_adv-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_baseu_xml-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_html-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_core-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_aui-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_xrc-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_baseu-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_stc-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_baseu-2.8.so.0()(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit)
错误:软件包:erlang-wx-20.0rc1-3.el7.centos.x86_64 (erlang-solutions)
需要:libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit)
您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 8 个已存在的 RPM 数据库问题, 'yum check' 输出如下:
icedtea-web-1.6.2-4.el7.x86_64 有缺少的需求 java-1.8.0-openjdk
ipa-client-4.4.0-12.el7.centos.x86_64 有已安装冲突 freeipa-client: ipa-client-4.4.0-12.el7.centos.x86_64
ipa-client-common-4.4.0-12.el7.centos.noarch 有已安装冲突 freeipa-client-common: ipa-client-common-4.4.0-12.el7.centos.noarch
ipa-common-4.4.0-12.el7.centos.noarch 有已安装冲突 freeipa-common: ipa-common-4.4.0-12.el7.centos.noarch
javapackages-tools-3.4.1-11.el7.noarch 有缺少的需求 python-javapackages = ('0', '3.4.1', '11.el7')
jline-1.0-8.el7.noarch 有缺少的需求 java >= ('0', '1.5', None)
1:libreoffice-core-5.0.6.2-3.el7.x86_64 有缺少的需求 java-headless >= ('1', '1.6', None)
1:libreoffice-ure-5.0.6.2-3.el7.x86_64 有缺少的需求 libjvm.so()(64bit)

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

5条回答 默认 最新

  • devmiao devmiao 2017-06-04 18:38
  • peach588 peach1.1 2020-03-24 22:27

    很明显啊,他需要安装erlang,这个安装好了就欧克了,在epel-release中可以下载到。
    但是应该非常慢,先把yum设置成国内的源再去下载

    点赞 1 评论 复制链接分享
  • wangyaninglm shiter 2017-06-05 03:01

    是不是JAVA冲突了?或者版本不对,可以尝试忽略依赖安装

    点赞 评论 复制链接分享
  • yanxilou 冷小鱼 2019-10-31 19:30

    https://blog.csdn.net/yanxilou/article/details/102843163
    可以参考我的,centos7装成功了。

    点赞 评论 复制链接分享
  • u011897138 剽悍潇洒 2019-11-21 14:53

    尝试一下先执行一下这个命令
    yum install epel-release

    点赞 评论 复制链接分享

相关推荐