编程介的小学生 2017-06-06 12:01 采纳率: 20.5%
浏览 707
已采纳

Largest prime factor

Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

Input
Each line will contain one integer n(0 < n < 1000000).

Output
Output the LPF(n).

Sample Input
1
2
3
4
5

Sample Output
0
1
2
1
3

  • 写回答

2条回答 默认 最新

  • 凝视深空 2017-06-06 13:00
    关注
     #include<iostream>
    #include<cmath>
    using namespace std;
    
    bool isPrime(int n)
    {
        for (int i = 2; i <= sqrt(n); ++i)
        {
            if (n % i == 0)
                return false;
        }
        return true;
    }
    
    int main()
    {
        int num;
        while(cin >> num)
        {
            if (isPrime(num))
            {
                int pos = 0;
                if (num > 1)
                    pos = 1;
                for (int i = 3; i <= num; i += 2)
                {
                    if (isPrime(i))
                        pos++;
                }
                cout << "position is:" << pos << endl;
            }
            else
                cout << "position is:" << 1 <<endl;
        }
        return 0;
    }
    
    

    图片说明

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 sqlite 附加(attach database)加密数据库时,返回26是什么原因呢?
  • ¥88 找成都本地经验丰富懂小程序开发的技术大咖
  • ¥15 如何处理复杂数据表格的除法运算
  • ¥15 如何用stc8h1k08的片子做485数据透传的功能?(关键词-串口)
  • ¥15 有兄弟姐妹会用word插图功能制作类似citespace的图片吗?
  • ¥200 uniapp长期运行卡死问题解决
  • ¥15 latex怎么处理论文引理引用参考文献
  • ¥15 请教:如何用postman调用本地虚拟机区块链接上的合约?
  • ¥15 为什么使用javacv转封装rtsp为rtmp时出现如下问题:[h264 @ 000000004faf7500]no frame?
  • ¥15 乘性高斯噪声在深度学习网络中的应用