lxping51
和善
2017-06-16 07:43
采纳率: 100%
浏览 896

android6.0以后的权限问题?

android6.0以后对权限的控制更为严格,官方对于老项目的处理是设置targetVersion<23的情况下,程序的运行是不会受到影响的。但是国内的部分手机厂商应该是修改了部分源码,导致程序崩溃。这种情况,有哪些比较好的处理方式呢?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • ziyejinwei1994
    ziyejinwei1994 2017-06-17 01:24
    已采纳

    只能加上动态申请权限了 推荐https://github.com/yanzhenjie/AndPermission

    点赞 评论
  • sinat_26761191
    sinat_26761191 2017-06-16 09:10

    导致崩溃,是不允许的,你先trycatch一下保证不崩溃,你再把错误代码贴出来大家看一下在解答呀

    点赞 评论
  • QingWaDaShu
    青蛙大侠 2017-06-27 08:31

    添加动态授权:build文件里 compile 'com.anthonycr.grant:permissions:1.0'

    点赞 评论

相关推荐