weixin_39975900
2020-12-09 00:08 阅读 4

Using ZED camera

Hi, this question may sound dumb but I wanted to be sure.

I'm still having problems with tuning the parameters. /stereo_camera/z_filtered_cloud wont't show up like the simulation. I was wondering if I edited the topic name correctly. I replaced /stereo_camera with zed. Then, launching it I get

[pcl::SampleConsensusModel::getSamples] Can not select 0 unique points out of 0! [pcl::RandomSampleConsensus::computeModel] No samples could be selected! [pcl::SACSegmentation::segment] Error segmenting the model! No solution found. [ WARN] [1513589100.539967224]: Could not estimate a planar model for the given dataset.

so I'm assuming that it's subscribing correctly, by looking at the publishers and subscribers of each topic via rostopic info

I also edited the code of ZED's SDK so that it publishes /stereo_camera/* instead of /zed/* and launched the original real_stereo_pattern.launch file but that doesn't seem to do the thing either...

Thank you in advance.

该提问来源于开源项目:beltransen/velo2cam_calibration

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • weixin_39685762 weixin_39685762 2020-12-09 00:08

    Hi . if publisher/subscribers are pointing to the required topics you shouldn't need to change the ZED driver. To that end, you can adjust the topics by using the tags inside in the .launch file.

    However, if you're not sure about if everything is connected properly, you can run rosrun rqt_graph rqt_graph and check which links are broken in your nodes graph.

    点赞 评论 复制链接分享
  • weixin_39975900 weixin_39975900 2020-12-09 00:08

    Hi . I see. I'll then stick to just changing the tags in the .launch file.

    I also checked the connection via rqt_graph, and everything seems to be fine... Here's the image of the rqt_graph when running real_stereo_pattern.launch and velo2cam_calibration.launch. I had to run the second one too, just so that the stereo_pattern node would show up. Does this mean I only have to adjust the parameters?

    velo2cam_test

    点赞 评论 复制链接分享
  • weixin_39975900 weixin_39975900 2020-12-09 00:08

    Hi Since /points2 won't show up correctly, I assumed that I needed to tune the stereo_manager parameters. So I'm going to adjust them according to the link below. http://wiki.ros.org/stereo_image_proc/Tutorials/ChoosingGoodStereoParameters I've never used this program before, and I think everything will turn out well once I get this straight.

    I will comment again after finishing all of this!

    点赞 评论 复制链接分享
  • weixin_39975900 weixin_39975900 2020-12-09 00:08

    I'm very sorry for the lack of updates.

    I came to a conclusion that I needed to make a better calibration board. It seems that I couldn't get the disparity image quite well with it. It also may be the fact that I haven't configured the ZED parameters yet, but that doesn't seem to be a big problem.

    So I believe one can calibrate with your system quite well even if they are using the ZED. I'll close this issue for now but if I ever get things straight, I will post something up again. Thank you very much for the advice!

    点赞 评论 复制链接分享

相关推荐