关于okHttpUtils的Android版本兼容性问题

我在项目使用了一个这样的依赖包(com.zhy:okhttputils:2.6.1),然后在Android版本4.4的模拟器上可以运行并获取数据,但是在Android版本7.0的手机上可以运行就是获取不了数据,请问各位大神这是什么原因?

4个回答

okHttpUtils使用的是HttpClient,而google在Android6.0以后不再支持HttpClient。可能是这个原因吧。你可以在build.gradle中添加useLibrary 'org.apache.http.legacy'就可以支持HttpClient了。

xchchx
xchchx 回复qq_35175297: 是在这个地方添加的吗 android { compileSdkVersion 25 buildToolsVersion "25.0.0" useLibrary 'org.apache.http.legacy' defaultConfig { minSdkVersion 15 } }
大约 2 年之前 回复
qq_35175297
qq_35175297 为什么加这句还是一样的结果??
大约 2 年之前 回复

这种第三方封装的okhttp估计没有很好做兼容性测试, 换用官方的吧

 com.squareup.okhttp3:okhttp:3.3.0

同楼上,库这些东西有的话还是用官方的好

建议直接用官方的OKHttp

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Android版本兼容性问题
我们先从一个实例开始 如图所示:当我们在build.gradle中设置minSdkVersion=8时,调用上诉API时会出现如图提示,无法运行在低于API8的手机上,这就是Android版本兼容性问题的体现; 下面是google官方给出的API平台版本:https://developer.android.google.cn/guide/topics/manifest/uses-sdk-e...
请教关于版本兼容性问题
1、我曾经用VB编过一个程序,其中用到DAO和串口通讯,在98、2000和XP中都能正常运行,安装程序是在98下制作的,但有点疑惑的是,能不能在2000或XP中制作安装程序,也能适应使用者的各个win版本?或者说,DAO和串口的支持控件和DLL,用XP和2000的版本安装到98中会不会冲突?rnrn2、我想将此程序增加英文版和繁体版,请教各位DX,在VB中使用资源文件的一些方法,或介绍一些参考书目。另外不同语文版本的支持DLL,OCX等应该如何打包?rnrn3、请各位DX介绍一些较好的能支持上述3种语文的打印模拟控件。
版本兼容性问题
现在编译时老是出现兼容性提示,提示如下rnrn"在类模块'ClsLogin' 中 'FrmLog' 有参数,并且/或返回类型与在版本兼容部件中类似的声明不兼容。"rnrn选项有:1.中断兼容性(B)rn 2.保留兼容性(高级)(P)rnrnrn这该如何处理?rn
关于VC6和Direct9x的版本兼容性问题!
我下载了DirectX SDK (April 2006),在VC6里配制后,拿教学光盘里的程序进行编译,总是出现一些莫名奇妙的语法错误,而且错误都是出现在Direct自带的头文件里,还有一些程序需要的头文件根本就不存在了(我找了书上说的相关目录,里面没有),请问是不是这个版本的Direct只支持.Net平台了啊!(在安装Direct时它先自动安装了.Net Framework1.1)rn
关于`babel-loader`和`babel-core`版本兼容性问题
安装babel-loader和babel-core出现问题 1.1 安装babel的转换工具包: npm i babel-core babel-loader babel-plugin-transform-runtime -D 1.2 安装完成后package.json中显示: “dependencies”: { “babel-core”: “^6.26.3”, “babel-loader”: ...
jdk 版本兼容性问题
原本是用的1.4.2的版本,现在升级为1.6.0的版本,JSP是否需要重新编译啊?rnrn1.6能兼容先前的版本吗?
Excel 版本兼容性问题
Excel 9.0 和 10.0 object lib操作的兼容性问题如何解决.如何使得引用9.0的类进行编程,然后在office xp上可以运行?rnrn比如在9.0中使用Excel.Range rng 对象.rnrng.Value = v;rn可以通过编译rn但是在10.0库中需要写成rnrng.set_Value(System.Reflection.Missing.Value, v);rnrn请问高手需要如何协调Excel 的版本
.Net Framework的版本兼容性问题
今天用VS2005做了个ASP.NET的网站,是基于.Net Framework 2.0的,在本机测试一切正常,于是上传到我的虚拟主机,我的是虚拟主机是买的支持ASP.NET的.但是无论怎么调试,总是报错,提示应用服务器错误.网址是http://www.nowpan.com,大家可以去看看.rnrn我现在就怀疑是不是因为我的网站是基于2.0的,而服务器那边还是装的1.1的环境,所以运行不了.rnrn在网上看了很多资料,包括英文的,很多地方都是说2.0不能向前兼容,也就是2.0开发的程序不能运行在1.1的环境下,但是1.1开发的程序经过一定的调试后可以运行在1.0和2.0下.rnrn不知道大家有没有遇到这个问题的,写出来大家交流一下.rn
IE版本兼容性问题
我机器上安装的是IE10,文件选择框是这个样子的rn[img=https://img-bbs.csdn.net/upload/201408/17/1408253706_242962.jpg][/img]rn可是我用IETester测试各个IE版本,从IE6到IE8都是显示以下效果rn[img=https://img-bbs.csdn.net/upload/201408/17/1408253792_738541.jpg][/img]rn根本就无法选择文件,html代码是rn[code=html]rn rn 导入Excel rn[/code]rnrn还有一个问题rn在IETester中,IE6和IE7的效果是这样的rn[img=https://img-bbs.csdn.net/upload/201408/17/1408254068_341715.jpg][/img]rnIE8以上正常,应该是rn[img=https://img-bbs.csdn.net/upload/201408/17/1408254128_538435.jpg][/img]rnhtml代码是rn[code=html]rn rn rn rn 3 Projectsrn rn rn 27 Tasksrn rn rn 7 Messagesrn rn rn 5 Filesrn rn rn rn[/code]rnrnCSS样式代码为rn[code=css]rn.well rn min-height: 20px;rn padding: 19px;rn margin-bottom: 20px;rn background-color: #f5f5f5;rn border: 1px solid #e3e3e3;rn -webkit-border-radius: 4px;rn -moz-border-radius: 4px;rn border-radius: 4px;rn -webkit-box-shadow: inset 0 1px 1px rgba(0, 0, 0, 0.05);rn -moz-box-shadow: inset 0 1px 1px rgba(0, 0, 0, 0.05);rn box-shadow: inset 0 1px 1px rgba(0, 0, 0, 0.05);rnrnrn.summary display:table; width:100%; padding:0; margin:0 0 20px 0;rn.summary ul margin:0; padding:0; overflow:hidden; display:table-row;rn.summary li margin:0; padding:19px; display:table-cell; border-right:1px solid #eee;rn.summary li:last-child border:none;rn.summary a display:block; font-size:1.2em; line-height:1.4em; text-transform:uppercase; color:#000;rn.summary .count display:block; font-size:1.75em; font-weight:bold;rnrn /* dashboard - ie fixes */rn .ie7 .summary display:block;rn .ie7 .summary ul margin:0; padding:0; overflow:hidden; display:block;rn .ie7 .summary li float:left;rn rn .ielt9 .summary .last border:none;rnrn[/code]
Android开源项目SlidingMenu 在5.0以上版本兼容性问题
Android开源项目SlidingMenu 在5.0以上版本中 切换Fragment时,Fragment中listview 上下滚动 页面不刷新 。切换到左菜单在返回里,listview中的数据加载到滚动的 位置。这个问题有人遇到吗?
GreenDao初体验——GreenDao与Android最新版本兼容性问题
GreenDao以前也玩过,但是由于项目原因,一直没用到,今天,想拿来玩玩,至于GreenDao具体怎么使用,我就不说了,在这里推荐一篇博客:GreenDao基础使用,先说一下我今天遇到的问题吧,我是安装这篇博客的流程来练习GreenDao的用法的,但是在中途突然之间就抛出了一个问题,我们先来瞧瞧是什么问题吧:12-02 02:40:29.385 9554-9554/com.morse.gre
struts2+spring与jdk版本兼容性问题,急~~~~~~~~~~~~~~~~~~
struts+spring用到的struts2-spring-plugin-2.0.9.jar包发现必须要使用jdk1.6的版本,不然报版本错误,rn请高手指点,我看了struts2-spring-plugin-2.0.9.jar的版本要求是:JDK1.5.0_08,我也在用这个jdk可是就是报错:rn[ERROR] 2009-03-05 18:47:34 [org.apache.catalina.core.StandardContext.filterStarrnt(StandardContext.java:3639)] Exception starting filter strutsrnjava.lang.UnsupportedClassVersionError: Bad version number in .class filern at java.lang.ClassLoader.defineClass1(Native Method)rn at java.lang.ClassLoader.defineClass(ClassLoader.java:620)rn at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12rn4)rn at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebapprnClassLoader.java:1852)rn at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoarnder.java:876)rn at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoarnder.java:1329)rn at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoarnder.java:1208)rn at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)rn at java.lang.ClassLoader.defineClass1(Native Method)rn at java.lang.ClassLoader.defineClass(ClassLoader.java:620)rn at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12rn4)rnrnrnrn用JDK1.6就不报错,可是公司必须得用JDK1.5,,,求救......解决办法 rn
bootsrap 和ice的ie版本兼容性问题
怎么让bootstrap在ie8和ie9中显示正常,我用的是ace dashboard模板
oracle 数据库导入导出的版本兼容性问题?
oracle 数据库导入导出的版本兼容性问题:rnQ1:低版本客户端可以导出高版本server的数据么?反之呢?rnQ2:导入导出时使用的client版本应该或者说必须一致么?rnQ3:低版本导出的.dmp文件可以导入到高版本里么? 反之呢?
内核版本兼容性问题,高手请进!
我的操作系统是redhat9,写了个内核模块测试程序,编译为.o文件,然后用insmod加载这个模块的时候,报如下错误:rnrnkernerl-module mismatchrnthe kernerl version is 2.4.20-8rnthe module version is 2.4.20rnrn请哪位大侠帮帮在下!多谢拉!
Android版本兼容
一、在用WebView展示网页时,如果网页里有图片,很多时候图片是不能够自适应屏幕的宽度的。大家在Android 4.4之前都会使用如下代码,设置图片自适应屏幕的宽度: WebSettings webSettings= contentWeb.getSettings(); webSettings.setLayoutAlgorithm(LayoutAlgorithm.SINGLE_COLUMN)
android的版本兼容
ViewAnimationUtils为例,如果没有进行版本判断会报错。因为这个只能在api21以上才能使用。 if(Build.VERSION.SDK_INT >= Build.VERSION_CODES.LOLLIPOP){ int cx = mShowAnswer.getWidth()/2; int cy = mShowA
OkHttpUtils
详见http://blog.csdn.net/huaxun66/article/details/52613439
okhttputils
张鸿洋大神封装的okhttputils,配合 okhttp3使用
迭代开发中如何处理版本兼容性问题
Deployment Target 和 Base SDK Deployment Target  指的是你的APP能支持的最低系统版本,如要支持iOS6以上,就设置成iOS6即可。 Base SDK  指的是用来编译APP的SDK(Software Development Kit)的版本,一般保持当前XCode支持的最新的就好,如iOS8.4。SDK其实就是包含了所有的你要用到的头文
ie8及其以下版本兼容性问题之响应式
ie8及其以下版本兼容性问题之响应式
ie8及其以下版本兼容性问题之圆角
ie8及其以下版本兼容性问题之圆角
ie8及其以下版本兼容性问题之文本省略
ie8及其以下版本兼容性问题之文本省略
请教一个vs2008和TFS 2010版本兼容性问题:
请问 vs2008项目是否可以加入到TFS2010 X64位的版本控制软件内。有个很奇怪现象。 我在32位平台搭建TFS2010,然后VS2008项目可以加入其中,但换成64位搭建TFS2010,确出现VS2008无法加入TFS2010内。rnrn请问大家有没有遇到过这类情况。
ie8及其以下版本兼容性问题之placeholder实现
ie8及其以下版本兼容性问题之placeholder实现
请教一个.NET Framwork版本兼容性问题
我用VS.net XP + vs.net 2003 + .net Framwork1.1开发一个Windows 应用程序,rn它可以在 Windows xp + .net framwork2.0 Runtime Components (仅仅.net framwork2.0)环境下运行吗?rnrn它可以在 Windows xp + WinFX Runtime Components(仅仅WinFX)环境下运行吗?rnrn在WinXP系统下开发winFX程序,安装了WinFX SDK 还需要安装 .net framwork1.1 或 .net framwork2.0 吗?rnrnVS.net 2003 + .net framwork 1.1 开发程序;VS.net 2005 + .net framwork 2.0 开发程序;WinFX程序rn都可以在 Windows Vista 下运行吗?前提是:直接安装的Vista不安装任何运行时组件(Runtime Components).
webpack中版本兼容性问题错误总结
1.安装webpack-dev-server报错,说需要webpack-cli原因,这两个之中某一个版本太高,重新安装低版本 2.安装webpack-cli之后仍然不能使用 3. npm WARN webpack-cli@3.0.8 requires a peer of webpack@^4.x.x but none is installed. You must install peer de...
Android OkhttpUtils上传图片和文件
#okhttp的使用-单个文件的上传 /** * 上传文件 * @param view */ public void uploadFile(View view) { File file = new File(Environment.getExternalStorage
OkHttputils
OkHttputils
okHttpUtils
okHttpUtils
[Skill]Android版本兼容器
Android版本兼容器随着Android版本一代代发布,碎片化的问题越来越严重,不过好在趋势上市面上的版本已经开始比较集中了。但我们终究还是要面对版本兼容问题。我们不能因为要用高版本方法而提高最低版本限制,高版本里炫酷的效果及高效的方法只会导致你的最低版本显示越来越高,而官方的解决方案(Support-v4)无疑是给了我们新的启示。
关于Keil5加载Keil4的工程时产生的版本兼容性问题
一个老的项目是用Keil4开发编译的,但是在用Keil5打开时,并不能正常的编译,甚至在设备里面没有办法正常显示对应的设备(如STM32F2xx) 针对这个问题,在Keil官网给出了解决办法。http://www2.keil.com/mdk5/legacy/ MDK v4 Legacy Support: MDK Version 5 uses Software Packs to support...
[Android]高低API版本兼容之
[Android]高低API版本兼容之
关于IE版本兼容的问题
我从网上Down了一个万年历和短消息的东东。rn在IE55+SP2下运行时正常,只弹出小窗体,rn但在IE60+SP1下运行时弹出都是大窗体。rnrn为什么,如何解决。使得在IE60+SP1运行仍只弹出小窗体。rn谢谢各位。
版本兼容
   Bitmap   2.3之前Bitmap对象与像素数据是分开存放的,Bitmap对象存在java Heap中而像素数据存放在Native Memory中,这时很有必要调用recycle回收内存。但是2.3之后,Bitmap对象和像素数据都是存在Heap中,GC可以回收其内存。      if (Build.VERSION.SDK_INT<=10) {           bitmap....
关于版本兼容的坑
前两天从服务器上git了公司正在开发的项目,结果出现了很多问题,现在总结一下这几天被坑后的感悟. 首先当项目git clone下来后,我直接将 minSdkVersion 21改成了19,然后重新build.编译没问题,接下来问题就一个接一个的来了. 当项目运行的时候直接报了这是什么错误呢,通过查找资料发现是RunStats.class这个类重复了,仔细一看果然.jar文件和src/main
Android封装简单的OKHttpUtils(接口回调)
在网络封装类中 public class OKHttpUtils { public OKHttpUtils() { } public OKHttpUtils get(String path) { OkHttpClient okHttpClient = new OkHttpClient(); final Request request = ...
关于oracle版本兼容的问题
有些了一个winform,该winform引用了一个dll,该dll使用了Oracle.DataAccess.dllrnrn运行的时候,报了一个未能加载文件或程序集“oracle.dataaccess version=9.2.0.401 。。。的错。rnrn于是我在程序里建了一个app.configrn里面是这样的rn[code=text]rnrnrn rn rn rn rn rn rn rn rnrn[/code]rnrn但还是报这个错
关于VB中的版本兼容
各位朋友:rn 请问VB中的不兼容、工程兼容与二进制兼容的区别?
关于版本兼容的问题
我们的软件升级后,数据结构调整(增加了一些属性),怎么把以前的文件在新程序里面读进来
相关热词 c#入门推荐书 c# 解码海康数据流 c# xml的遍历循环 c# 取 查看源码没有的 c#解决高并发 委托 c#日期转化为字符串 c# 显示问号 c# 字典对象池 c#5.0 安装程序 c# 分页算法