weixin_39756696
weixin_39756696
2020-12-09 00:58

Tooltips no longer work in Xfce, LXDE and standalone applet

The tooltips no longer work with multiload-ng 1.3.0 in Xfce (tested in Xubuntu), LXDE (tested in Lubuntu), and the standalone applet. I tried setting them to both simple and advanced, both with the same result.

该提问来源于开源项目:udda/multiload-ng

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39762348 weixin_39762348 5月前

    OK, then the culprit is a known GTK limitation (race between query-tooltip signal timeout and gtk_widget_set_tooltip_text). I will fix that in next versions, as it requires some work: fixing needs building custom widgets and make them act as standard tooltips.

    Exactly for this reason, for low update intervals, a warning icon pops up next to interval value.

    At the moment, I adjusted the value which triggers the display of warning, so the user is informed of that. Also, I raised the default update interval from 500 ms to 1000 ms. Default configuration should now be OK.

    I will release v1.3.1 today, with this fix and some other little things. Closing.

    点赞 评论 复制链接分享
  • weixin_39762348 weixin_39762348 5月前

    I suppose this is a GTK+2 build. Could be useful to know whether this happens on GTK+3 too. I will try in a VM in a few hours.

    Edit: I can confirm that GTK+3 builds show tooltips correctly.

    点赞 评论 复制链接分享
  • weixin_39756696 weixin_39756696 5月前

    Indeed, it was GTK2. Xubuntu and Lubuntu don't use GTK3 so I couldn't test that part, and in MATE it worked with both GTK2 and GTK3.

    点赞 评论 复制链接分享
  • weixin_39762348 weixin_39762348 5月前

    Could you please try raising the update interval and see if tooltips show up? In my tests, they do. Knowing this allows me to better locate the problem

    点赞 评论 复制链接分享
  • weixin_39756696 weixin_39756696 5月前

    Yes, increasing the update interval by just one step gets the tooltips to work.

    点赞 评论 复制链接分享

相关推荐