weixin_39942400
2020-12-09 02:52 阅读 3

MarySpeech WebGui Borked

webgui : ------ java.lang.NoSuchMethodException: could not find MarySpeech.installSelectedLanguagesAndVoices(ordinal 1) in declared methods

Which is true - the installer has the method, but not MarySpeech .. perhaps it should proxy the method ?

该提问来源于开源项目:MyRobotLab/myrobotlab

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

5条回答 默认 最新

  • weixin_39897687 weixin_39897687 2020-12-09 02:52

    no ... the webgui needs to change that is how it used to be noWorky earlier Now it's using installComponentsAcceptLicense(String component) & installComponentsAcceptLicense(String[] components)

    If it even gets that far

    点赞 评论 复制链接分享
  • weixin_39587822 weixin_39587822 2020-12-09 02:52

    In my current eclipse copy of develop I get an error on MaryUtils.java, toGermanLetterTable line 592. But I do not understand what the function is doing and the character-comments show up as gibberish? Do I need special settings in Eclipse (neon) to see what is going on?

    点赞 评论 复制链接分享
  • weixin_39788256 weixin_39788256 2020-12-09 02:52

    , This file is located to mrl\src\org.myrobotlab.MarySpeechUtils.java . In Eclipse, clic on it, and in the menu bar, go to file->properties. This will open a new window. In the tab "ressource", you will see " text file encoding" at the bottom. Select "other" and "UTF-8". This should correct the error .

    点赞 评论 复制链接分享
  • weixin_39587822 weixin_39587822 2020-12-09 02:52

    , worked like you explained, thanks. However still can't figure out what the code does and why I get so many nonstandard characters in the comments?

    点赞 评论 复制链接分享
  • weixin_39942400 weixin_39942400 2020-12-09 02:52

    Appears to be working in the webgui (original issue)

    点赞 评论 复制链接分享

相关推荐