weixin_39618806
weixin_39618806
2020-12-09 08:15

Exploded war deploy fails when http2 enabled

If I configure jetty to run http1, I can successfully run my webapp from IntelliJ. If I enable http2, server starts but webapp doesn't get deployed. I'm using the exploded war deploy. Any idea?

该提问来源于开源项目:guikeller/jetty-runner

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39618806 weixin_39618806 5月前

    I already starred you. ;-) To rate, I will wait a bit, as it doesn't work for me yet.

    Now that I could finally test it, I get the following exception: https://gist.github.com/elmart/eaee72a98a8eb0bf58536bd01dd9b945

    I'm on OSX 10.11.6, jdk1.8.0_60, jetty 9.3.12. Attached my jetty's start.ini (renamed as start.ini.txt to be able to upload). start.ini.txt Also attached my Jetty Runner config. screen shot 2016-10-02 at 21 58 28

    Any idea?

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 5月前

    Hi

    It's classpath issue, the most common causes are to do with: ASM / CGLIB.

    http://stackoverflow.com/questions/12166382/java-lang-incompatibleclasschangeerror-implementing-class-deploying-to-app-engi https://github.com/ragnor/simple-spring-memcached/issues/22

    Good luck with your project. :+1:

    Cheers, Gui

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 5月前

    Hi

    The HTTP2 is a feature that has been added on Jetty-9.3. And the plugin uses Jetty-9.2 to kick start things under the hood which does not have that.

    I will have a look on "Jetty-9.3.11.v20160721" and if is stable enough I will update the plugin. In the meantime I will keep this issue / bug open as a feature request.

    Cheers, Gui

    点赞 评论 复制链接分享
  • weixin_39618806 weixin_39618806 5月前

    Were you able to try it?

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 5月前

    Sorry not yet, been busy with work and other commitments.. I will try during the weekend and will get a new release out if all goes well.

    点赞 评论 复制链接分享
  • weixin_39618806 weixin_39618806 5月前

    Great! Dependency on Java 8 is no problem for me. I'll try it tomorrow as soon as I get to work. Thx very much for taking my suggestion into account.

    点赞 评论 复制链接分享

相关推荐