Lemostic
lemostic
采纳率61.5%
2020-12-16 15:52 阅读 13
已采纳

IDEA部署项目无法运行

环境:jdk1.8 ,tomcat 8.0 ,Spring 3.0.5

求助,运行maven项目一直提示以下错误

 

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

3条回答 默认 最新

  • 已采纳
    qq_25376897 qq_25376897 2020-12-16 16:25

    Spring 3不完全兼容jdk1.8,如果用了8的语法,有可能会报这个错,你检查下,如果是这个原因导致的,可以改用Spring 4或者改用jdk1.7(或者代码里面不使用1.8独有的语法,不过这么做实际上就相当于降低了jdk)

    点赞 1 评论 复制链接分享
  • new_wugan new_wugan 2020-12-16 16:05

    环境问题,看下依赖,

    点赞 评论 复制链接分享
  • qq_43491705 Hand_Power 2020-12-16 17:10

    下标越界了  

    点赞 评论 复制链接分享

相关推荐