weixin_39818521
weixin_39818521
2020-12-25 23:18

Can't install elastalert-kibana-plugin-1.0.3-6.8.0.zip to Kibana 6.8.3

I have this:


[root bin]# ./kibana-plugin install https://github.com/bitsensor/elastalert-kibana-plugin/releases/download/1.0.3/elastalert-kibana-plugin-1.0.3-6.8.0.zip
Attempting to transfer from https://github.com/bitsensor/elastalert-kibana-plugin/releases/download/1.0.3/elastalert-kibana-plugin-1.0.3-6.8.0.zip
Transferring 22930897 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Plugin installation was unsuccessful due to error "Plugin elastalert-kibana-plugin [6.8.0] is incompatible with Kibana [6.8.3]"

该提问来源于开源项目:bitsensor/elastalert-kibana-plugin

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39681486 weixin_39681486 3月前

    Running into the same problem. Upgrade path from 6.7.2 to es 7.3.1 steps us through 6.8.3 but elastalert doesn't appear to have a 6.8.3 support package. Going to back off to es6.8.0 so I can continue with elastalert in tact.

    点赞 评论 复制链接分享
  • weixin_39573981 weixin_39573981 3月前

    Whether it worked for you?

    点赞 评论 复制链接分享
  • weixin_39681486 weixin_39681486 3月前

    Yeah, moving back to 6.8.0 worked fine. We've subsequently bumped up successfully to 7.4.0

    点赞 评论 复制链接分享
  • weixin_39922642 weixin_39922642 3月前
    
    cd /tmp
    curl -L -O https://github.com/bitsensor/elastalert-kibana-plugin/releases/download/1.1.0/elastalert-kibana-plugin-1.1.0-7.5.0.zip
    mv elastalert-kibana-plugin-1.1.0-7.5.0.zip elastalert-kibana-plugin-1.1.0-6.8.3.zip
    unzip elastalert-kibana-plugin-1.1.0-6.8.3.zip kibana/elastalert-kibana-plugin/package.json
    sed -i "s/7\.5\.0/6\.8\.3/g" kibana/elastalert-kibana-plugin/package.json
    zip lastalert-kibana-plugin-1.1.0-6.8.3.zip kibana/elastalert-kibana-plugin/package.json
    /usr/share/kibana/bin/kibana-plugin install file:///tmp/elastalert-kibana-plugin-1.1.0-6.8.3.zip
    
    点赞 评论 复制链接分享