请各位大神帮忙指点指点

请各位大神帮忙指点指点,我在网上搜到的几乎都是删除jar包jsp-api.jar和servlet-api.jar或者将jdk1.6改成1.5,但改完之后的又出现了另外的问题,那些问题的解决方法又是将改动之后的再改回去,我就不知道怎么办了
错误提示:
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: /manager/index.jsp(2,0) Unable to read TLD "META-INF/c-1_0-rt.tld" from JAR file "file:/C:/Users/Administrator/Workspaces/wenjian1/.metadata/.me_tcat/webapps/survey/WEB-INF/lib/standard-1.1.2.jar": org.apache.jasper.JasperException: Failed to load or instantiate TagLibraryValidator class: org.apache.taglibs.standard.tlv.JstlCoreTLV
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40)
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407)
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:88)
org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:334)
org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:367)
org.apache.jasper.compiler.Parser.parseDirective(Parser.java:468)
org.apache.jasper.compiler.Parser.parseElements(Parser.java:1426)
org.apache.jasper.compiler.Parser.parse(Parser.java:133)
org.apache.jasper.compiler.ParserController.doParse(ParserController.java:216)
org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:167)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:306)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:273)
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:566)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:39)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:264)
org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107)
org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:110)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:217)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.logout.LogoutFilter.doFilter(LogoutFilter.java:108)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:191)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:90)
org.springframework.orm.hibernate3.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:173)
org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:77)
org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:78)
org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:77)
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.13 logs.

Apache Tomcat/6.0.13

3个回答

    首先确定你的环境变量是1.5/1.6然后在在你的配置里配置mavent、Tomcat,你的file:/C:/Users/Administrator/Workspaces/wenjian1/.metadata/.me_tcat/webapps/survey/WEB-INF/lib/standard-1.1.2.jar": 是啥情况!缺包不知道啊!
hx120721
hx120721 我换了几个Tomcat版本不管用,是不是myeclipse的版本问题
大约 3 年之前 回复
hx120721
hx120721 我换了几个Tomcat版本不管用,是不是木叶丽萍色、
大约 3 年之前 回复
qq_34730277
南宫文凯 回复hx120721: 版本不兼容?
大约 3 年之前 回复
hx120721
hx120721 standard-1.1.2.jar这个jar包我有啊,这句话的意思是说不能从standard-1.1.2.jar这个jar包下读取META-INF/c-1_0-rt.tld这个文件或者说路径。
大约 3 年之前 回复

你是不是缺少了JSTL的jar包啊,还有jsp-api.jar和servlet-api.jar是可以不要的,因为tomcat有。jdk版本尽量高吧,因为很多都是向下兼容的。

hx120721
hx120721 我这jstl也有,那两个jar包删除之前报500,删除之后报404,jdk版本1.6,更改成1.5之后项目报错。
大约 3 年之前 回复

这个问题我刚遇到过哈哈,我告诉你解决办法
项目中的诸如:catalina.jar、jsp-api.jar、servlet-api.jar、javax.servlet.jar、javax.servlet.jsp.jar等包和应用服务器(JBoss/Tomcat等)中的包重复且比其版本低,应用服务器在启动时会优先加载项目中的包,这样就导致和应用服务器中的其它包不匹配。可把重复的包从项目中删除,或将应用服务器下的这些包拷贝到项目中,重启服务即可。

hx120721
hx120721 谢啦,我解决啦,tomcat的问题
大约 3 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问