javarookier
2017-06-27 08:37
采纳率: 20%
浏览 11.9k
已采纳

springboot启动报错Application startup failed

除了是包依赖,还有可能是别的问题吗

这是pom,我也没看到一样的啊
4.0.0

<artifactId>xxmy</artifactId>
<dependencies>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-context</artifactId>
        <version>3.2.8.RELEASE</version>
    </dependency>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-context</artifactId>
        <version>4.3.7.RELEASE</version>
    </dependency>
    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-webmvc</artifactId>
        <version>3.2.8.RELEASE</version>
    </dependency>
</dependencies>
<groupId>XZCY</groupId>
<packaging>pom</packaging>
<version>0.0.1</version>
<modules>
    <module>backend</module>
    <module>domain</module>
    <module>frontend</module>
</modules>


<parent>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-parent</artifactId>
    <version>1.5.2.RELEASE</version>
    <relativePath/> <!-- lookup parent from repository -->
</parent>
<properties>
    <!-- 工程编码方式 -->
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <!-- 指定jdk版本 -->
    <jdk.version>1.8</jdk.version>
    <!-- spring boot 版本-->
    <springboot.version>1.5.2.RELEASE</springboot.version>
    <!-- 数据库连接池版本 -->
    <druid.version>1.0.23</druid.version>
    <!--&lt;!&ndash; alibaba dubbox 版本&ndash;&gt;-->
    <com.alibaba.dubbo.version>2.8.4</com.alibaba.dubbo.version>
    <!-- spring boot dubbox版本 -->
    <spring.boot-starter.dubbox.version>0.0.1</spring.boot-starter.dubbox.version>
    <!--zookeeper 版本-->
    <zookeeper.version>3.4.8</zookeeper.version>
    <!-- 配合spring mvc 序列化JSON -->
    <org.thymeleaf.extras.springsecurity4.version>2.1.2.RELEASE</org.thymeleaf.extras.springsecurity4.version>
    <!-- 配合spring mvc 序列化JSON -->
    <nz.net.ultraq.thymeleaf.dialect.version>1.3.3</nz.net.ultraq.thymeleaf.dialect.version>
    <!-- mysql数据库连接驱动版本 -->
    <mysql.cnnector.java.driver.version>5.1.38</mysql.cnnector.java.driver.version>
    <!-- lombok -->
    <lombok.version>1.16.6</lombok.version>
    <!-- dubbox kryo序列化-->
    <kryo.version>2.24.0</kryo.version>
    <kryoSerializers.version>0.26</kryoSerializers.version>

</properties>
<!-- 工程依赖 -->
<dependencyManagement>
    <!-- 工程依赖jar包 -->
    <dependencies>
        <!-- 序列化JSON -->
        <dependency>
            <groupId>com.alibaba</groupId>
            <artifactId>fastjson</artifactId>
            <version>LATEST</version>
        </dependency>

        <!-- 数据库连接池 -->
        <dependency>
            <groupId>com.alibaba</groupId>
            <artifactId>druid</artifactId>
            <version>${druid.version}</version>
        </dependency>

        <!-- mysql数据库连接驱动 -->
        <dependency>
            <groupId>mysql</groupId>
            <artifactId>mysql-connector-java</artifactId>
            <version>${mysql.cnnector.java.driver.version}</version>
        </dependency>

        <!--发送邮箱-->
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-mail</artifactId>
            <version>${springboot.version}</version>
        </dependency>

        <!--日期格式化-->
        <dependency>
            <groupId>org.webjars</groupId>
            <artifactId>momentjs</artifactId>
            <version>LATEST</version>
        </dependency>

        <dependency>
            <groupId>org.webjars</groupId>
            <artifactId>Eonasdan-bootstrap-datetimepicker</artifactId>
            <version>LATEST</version>
        </dependency>

        <!--配合spring mvc 序列化JSON-->
        <!--<dependency>-->
            <!--<groupId>org.thymeleaf.extras</groupId>-->
            <!--<artifactId>thymeleaf-extras-springsecurity4</artifactId>-->
            <!--<version>${org.thymeleaf.extras.springsecurity4.version}</version>-->
        <!--</dependency>-->
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-thymeleaf</artifactId>
            <version>${springboot.version}</version>
        </dependency>
        <dependency>
            <groupId>nz.net.ultraq.thymeleaf</groupId>
            <artifactId>thymeleaf-layout-dialect</artifactId>
            <version>${nz.net.ultraq.thymeleaf.dialect.version}</version>
        </dependency>
        <!--end配合spring mvc 序列化JSON-->

        <!-- 发送邮件 -->
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-mail</artifactId>
            <version>${springboot.version}</version>
        </dependency>
        <!--dubbox-->
        <dependency>
            <groupId>com.alibaba</groupId>
            <artifactId>dubbo</artifactId>
            <version>${com.alibaba.dubbo.version}</version>
        </dependency>
        <!--dubbox kryo序列化-->
        <dependency>
            <groupId>com.esotericsoftware.kryo</groupId>
            <artifactId>kryo</artifactId>
            <version>${kryo.version}</version>
        </dependency>
        <dependency>
            <groupId>de.javakaffee</groupId>
            <artifactId>kryo-serializers</artifactId>
            <version>${kryoSerializers.version}</version>
        </dependency>

        <!--zookeeper-->
        <dependency>
            <groupId>org.apache.zookeeper</groupId>
            <artifactId>zookeeper</artifactId>
            <version>${zookeeper.version}</version>
            <type>pom</type>
        </dependency>

        <!-- zookeeper client -->
        <dependency>
            <groupId>com.github.sgroschupf</groupId>
            <artifactId>zkclient</artifactId>
            <version>LATEST</version>
        </dependency>

        <dependency>
            <groupId>com.101tec</groupId>
            <artifactId>zkclient</artifactId>
            <version>0.9</version>
        </dependency>

        <!-- lombok -->
        <dependency>
            <groupId>org.projectlombok</groupId>
            <artifactId>lombok</artifactId>
            <version>${lombok.version}</version>
        </dependency>


        <!-- https://mvnrepository.com/artifact/joda-time/joda-time -->
        <dependency>
            <groupId>joda-time</groupId>
            <artifactId>joda-time</artifactId>
            <version>${joda-time.version}</version>
        </dependency>

        <dependency>
            <groupId>com.github.axet</groupId>
            <artifactId>kaptcha</artifactId>
            <version>0.0.9</version>
        </dependency>
    </dependencies>
</dependencyManagement>

<!-- 项目构建设置 -->
<build>
    <plugins>
        <!-- maven 编译插件 -->
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.2</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
                <encoding>UTF-8</encoding>
            </configuration>
        </plugin>

        <!-- maven 源码打包插件 -->
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-source-plugin</artifactId>
            <executions>
                <execution>
                    <id>attach-sources</id>
                    <goals>
                        <goal>jar</goal>
                    </goals>
                </execution>
            </executions>
        </plugin>
    </plugins>
</build>

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • lzwqjaycnoo 2017-06-28 02:25
    已采纳

    xxmy


    org.springframework
    spring-context
    3.2.8.RELEASE


    org.springframework
    spring-context
    4.3.7.RELEASE


    org.springframework
    spring-webmvc
    3.2.8.RELEASE


    XZCY</groupId

    这里引用jar是做什么,springboot不是自己装配了吗? webmvc只要依赖

    org.springframework.boot
    spring-boot-starter-web

        就可以了。
        另外:<!-- 发送邮件 -->
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-mail</artifactId>
            <version>${springboot.version}</version>
        </dependency>
                引入了两次。
    
    点赞 打赏 评论
  • loongshawn 2017-06-27 11:00

    建议你把properties、plugins等选择性的去掉,逐步排查。

    点赞 打赏 评论

相关推荐 更多相似问题