weixin_39775976
weixin_39775976
2020-12-26 02:06

AppImage does not run on Ubuntu 14.04

  • Operating system name and version: e.g. Debian 8

Ubuntu 14.04

  • CPU-X installation type: e.g. package/portable version/built from source

AppImage

  • cpu-x --issue-fmt command output (as root):

Does not run.

cpu-x: /lib/x86_64-linux-gnu/libkeyutils.so.1: version 'KEYUTILS_1.5' not found (required by /run/firejail/appimage/.appimage-6998/usr/lib/libkrb5.so.3)

Please make sure none of the blacklisted libraries are bundled. And please use a version of libcurl that does not need Kerberos.

Reference: https://github.com/AppImage/appimage.github.io/pull/665

该提问来源于开源项目:X0rg/CPU-X

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39603492 weixin_39603492 4月前

    That's a .deb package. OpenSUSE uses .rpm packages.

    This AppImage works on Ubuntu 16.04 (Xenial) and later. I'm sorry, but I'll not waste time to support a 4 years-old distro.

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 4月前

    The proper way would be to compile libcurl without Kerberos on openSUSE, I guess. Ubuntu 14.04 is currently the oldest still-supported LTS release and a prerequisite to get listed on https://appimage.github.io/apps/. There are still people running it (in fact, I got the request to support CentOS 6 not to long ago).

    点赞 评论 复制链接分享
  • weixin_39603492 weixin_39603492 4月前

    Hello,

    This AppImage is built on OBS's OpenSUSE 42.3 VM (appimage.yml). I don't know where I can find a version of libcurl that does not need Kerberos. Any idea?

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 4月前

    A a version of libcurl that does not need Kerberos is mentioned in https://github.com/AppImage/AppImages/issues/187, namely https://launchpad.net/%7Edjcj/+archive/ubuntu/libcurl-slim cc

    点赞 评论 复制链接分享

相关推荐