weixin_39646970
weixin_39646970
2020-12-26 04:43

trouble shoothing mode

Alors j'ai installer jarvis et l'installation s'est bien passé sauf que quand je lance le programme il comprend la trigger phrase qui est dans mon cas "miroir" et me répond "puis-je vous aider" comme je l'ai configuer mais ne comprend pas les autre commandes (comme aide, bonjour etc..) voici le résultat du lancement du prog en mode troubleshooting


------------ Config ------------
jv_branch            master 
jv_version           17.04.12 
jv_arch              armv7l 
jv_os_name           raspbian 
jv_os_version        8 
language             fr_FR 
play_hw              false 
rec_hw               false 
speaker              Default 
microphone           Default 
recorder             sox 
trigger_stt          snowboy 
command_stt          wit 
tts_engine           google 
--------------------------------

DEBUG: program_startup hook
miroir: salut
DEBUG: start_speaking hook
DEBUG: stop_speaking hook
User defined commands:
*AIDE*          *BONJOUR*|*SALUT*   *COMMENT*APPELLE*
*MERCI*         *AU REVOIR*|*BYE*   ANNULE*|TERMINE*
ENCORE*         *TEST*          *VERSION*
*REPETE (*) ET (*)  *CA VA*         >*OUI*
>*NON*|*PAS*
miroir: Waiting to hear 'miroir'
isimm: (listening...)
DEBUG: models=miroir
INFO:snowboy:Ticks: [2, 20, 5, -1]
INFO:snowboy:Keyword 1 detected at time: 2017-04-21 02:09:30
INFO:snowboy:Ticks status: 2 1 0 1
DEBUG: modelid=0
miroir
DEBUG: entering_cmd hook
miroir: puis-je vous aider?
DEBUG: start_speaking hook
DEBUG: stop_speaking hook
isimm: (listening...)
DEBUG: start_listening hook
utils/timeout.sh 10 rec -V1 -q -r 16000 -c 1 -b 16 -e signed-integer --endian little /dev/shm/jarvis-record.wav gain 2 silence 1 0.1 1% 1 0.5 1% trim 0 5
DEBUG: speech duration was 50 (10 = 1 sec)
WARNING: too long for a command (max 4 secs), ignoring...
HELP: try in order the following options
1) wait longer between voice commands
2) reduce ambiant background noise
3) decrease mic sensitivity in Settings > Audio
4) increase Min Silence Level to Stop
DEBUG: stop_listening hook
(listening...)
DEBUG: start_listening hook
utils/timeout.sh 10 rec -V1 -q -r 16000 -c 1 -b 16 -e signed-integer --endian little /dev/shm/jarvis-record.wav gain 2 silence 1 0.1 1% 1 0.5 1% trim 0 5
DEBUG: speech duration was 50 (10 = 1 sec)
WARNING: too long for a command (max 4 secs), ignoring...
HELP: try in order the following options
1) wait longer between voice commands
2) reduce ambiant background noise
3) decrease mic sensitivity in Settings > Audio
4) increase Min Silence Level to Stop
DEBUG: stop_listening hook
(listening...)
DEBUG: start_listening hook
utils/timeout.sh 10 rec -V1 -q -r 16000 -c 1 -b 16 -e signed-integer --endian little /dev/shm/jarvis-record.wav gain 2 silence 1 0.1 1% 1 0.5 1% trim 0 5
DEBUG: speech duration was 50 (10 = 1 sec)
WARNING: too long for a command (max 4 secs), ignoring...
HELP: try in order the following options
1) wait longer between voice commands
2) reduce ambiant background noise
3) decrease mic sensitivity in Settings > Audio
4) increase Min Silence Level to Stop
DEBUG: stop_listening hook
DEBUG: 3 attempts failed, end of conversation

DEBUG: exiting_cmd hook
miroir: Waiting to hear 'miroir'
isimm: (listening...)
DEBUG: models=miroir
INFO:snowboy:Ticks: [2, 20, 5, -1]
INFO:snowboy:Keyword 1 detected at time: 2017-04-21 02:10:31
INFO:snowboy:Ticks status: 2 1 1 1
DEBUG: modelid=0
miroir
DEBUG: entering_cmd hook
miroir: puis-je vous aider?
DEBUG: start_speaking hook
DEBUG: stop_speaking hook
isimm: (listening...)

ps: quand je le lance en mode keyboard ça marche et il me répond correctement

该提问来源于开源项目:alexylem/jarvis

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39646970 weixin_39646970 4月前

    ça marche pas :(

    点赞 评论 复制链接分享
  • weixin_39873208 weixin_39873208 4月前

    C'est quoi qui marche pas? Tu as essayé de faire l'auto-ajust audio level? Tu es allé jusqu'au bout? Tu as eu un message d'erreur?

    点赞 评论 复制链接分享
  • weixin_40000999 weixin_40000999 4月前

    Pas de réponse depuis 7 jours, je clôture l'issue. S'il y a de l'évolution, n'hésites pas à le ré-ouvrir 😉

    点赞 评论 复制链接分享
  • weixin_39873208 weixin_39873208 4月前

    Tu as ce message:

    
    WARNING: too long for a command (max 4 secs), ignoring...
    

    Essaye de refaire Settings > Audio > Audo-adjust

    点赞 评论 复制链接分享

相关推荐