weixin_39673601
weixin_39673601
2020-12-26 08:57

Problem of the gazebo_ros_planar_move plugin

Hi! I use ros hydro + gazebo 1.9.1, my os is Ubuntu 12.04 32bit. The gazebo_ros_planar_move plugin can not make the model in touch with the ground when moving, which means that the model just "floats" above the ground when it is put there (by spawn or manual translation in gazebo gui) with this plugin (when without this plugin, the model falls down quickly as expected). I suppose the problem comes from that the linear velocity of z direction of the model is set to zero, and it is also not suitable to set this velocity to some constant value, then the model would stick to the ground, and it is quite difficult for the model to move away. I understand that this is just a simple plugin for the model motion control in gazebo, but I still hope there could be some possible solutions for this issue. Thanks for any help!

该提问来源于开源项目:ros-simulation/gazebo_ros_pkgs

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39758288 weixin_39758288 4月前

    : I have a feeling that you are not spawning your models at the correct height. If you set the z appropriately right at the start, the object will still "float" but on the ground.

    Additionally, if you lower the inertia along the z axis, I believe the object should start come back down to the ground if gravity is enabled.

    点赞 评论 复制链接分享
  • weixin_39673601 weixin_39673601 4月前

    Thanks for your reply! I have tried what you suggested, including setting the robot's inertia to be very small (0.001), unfortunately, the robot still floats, but does not fall down (or falls down quite slowly). For your reference, the robot runs on a simulated unflat outdoor terrain with small mountains and caves.

    点赞 评论 复制链接分享
  • weixin_39758288 weixin_39758288 4月前

    I would highly recommend not running the planar_move plugin on non-flat terrain, though I suspect you have your reasons. Is it a 2 wheeled or a 4 wheeled robot? Give the diff_drive or skid_steer_drive plugin a try.

    I'll leave this bug report open for now as there are some problems that could be fixed with the plugin. I will try and get to them as soon as I can, but it maya be 2-3 weeks before that happens.

    点赞 评论 复制链接分享
  • weixin_39843151 weixin_39843151 4月前

    I think I'm in the similar (or the same) situation with .

    Since you're experienced with Model Plugin, can you provide any idea of how to remedy this issue so that others can try updating the code?

    点赞 评论 复制链接分享
  • weixin_39843151 weixin_39843151 4月前

    I asked on answers forum too about this where I also provided a video of a simple workaround.

    点赞 评论 复制链接分享

相关推荐