weixin_39603613
weixin_39603613
2020-12-26 12:37

jetty-6 downgrade

Embedding jetty-9 caused conflicts with Tomcat 6 (and a few Tomcat 7 versions) as jetty-9 pulls in servlet 3.1 which gets dropped by tomcat. Hence going back to jetty-6 based on servlet 2.5

该提问来源于开源项目:Netflix/karyon

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39805644 weixin_39805644 4月前

    NetflixOSS » karyon » karyon-pull-requests #35 SUCCESS This pull request looks good

    点赞 评论 复制链接分享
  • weixin_39927993 weixin_39927993 4月前

    in the same time, Jetty-6, wait you were on Jetty-7 originally

    点赞 评论 复制链接分享
  • weixin_39927993 weixin_39927993 4月前

    Jetty-7 causing the same compatibility problem with new Jetty in the same area, servlet-api 2.5. I hope I won't be shot in here, could you maybe provide two set of binaries ( Jetty 7 and Jetty 9+ ) ?

    点赞 评论 复制链接分享
  • weixin_39603613 weixin_39603613 4月前

    We have v2.3.0 w/ jetty7 I think we can build one w/ jetty-9 commit sha if we need a release. For now - jetty-6 seems a safer approach w.r.t existing tomcat 6 version compatibility

    On Tue, Apr 21, 2015 at 4:04 PM, maksimlikharev notifications.com wrote:

    Jetty-7 causing the same compatibility problem with new Jetty in the same area, servlet-api 2.5. I hope I won't be shot in here, could you maybe provide two set of binaries ( Jetty 7 and Jetty 9+ ) ?

    — Reply to this email directly or view it on GitHub https://github.com/Netflix/karyon/pull/217#issuecomment-94967329.

    Amit Joshi, ajoshi.com

    点赞 评论 复制链接分享
  • weixin_39927993 weixin_39927993 4月前

    Honestly it was a big sight of relief, when I saw Jetty 9 in the webadmin, that was causing so much pain ( that is Jetty 7 servlet-api 2.5 ), pretty much we would have to build our own version every time we switch to new Karyon version. I'm sure other people who are not using tomcat feel the same. Basically parallel versions would really, really help a lot, but I know it's more work for you. Thank you.

    点赞 评论 复制链接分享

相关推荐