weixin_39621178
weixin_39621178
2020-12-26 14:48

gdal error

hi, I am using django 1.11 when i run the migrate command it give me gdal related error but you mentioned that i dont need gdal for this. can you please help me in this regard

该提问来源于开源项目:makinacorpus/django-leaflet

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39955925 weixin_39955925 4月前

    gdal is a requirements for GeoDjango since the 1.11 https://docs.djangoproject.com/en/1.11/releases/1.11/#id1

    Are you using Django 1.11 and part of GeoDjango?

    点赞 评论 复制链接分享
  • weixin_39888807 weixin_39888807 4月前

    I am in fact using Django 1.11, but I don't use GeoDjango that I'm aware of. I thought GeoDjango wouldn't be a requirement for django-leaflet.

    点赞 评论 复制链接分享
  • weixin_39955925 weixin_39955925 4月前

    I guess that it is because django-leaflet use some part of geodjango for its form fields: https://github.com/makinacorpus/django-leaflet/blob/master/leaflet/forms/fields.py#L8

    点赞 评论 复制链接分享
  • weixin_39955925 weixin_39955925 4月前

    django-leaflet does not have migrations nor model fields. In which migration do you have an issue and what is the traceback ?

    点赞 评论 复制链接分享
  • weixin_39888807 weixin_39888807 4月前

    Hi, I have the same issue. It occurs with the example given. I installed all the requirements in a fresh virtualenv and tried to migrate, and then I got an error that GDAL was not found.

    点赞 评论 复制链接分享

相关推荐