weixin_39626089
weixin_39626089
2020-12-26 19:21

the -d parameter doesn't provide me with diagnostic information

Any time I use the -d parameter I get a message about telemetry is turned on, but I get no error/warning/trace output in the console. I can't figure out why my nuget template package will not install with dotnet -d new -i c:\path\to\nupkg

Steps to reproduce

Run a command with dotnet -d and no extra information is displayed.

Expected behavior

I get more debug output to understand what the command is doing.

Actual behavior

Only Telemetry is: Enabled is displayed.

Environment data

dotnet --info output:

.NET Core SDK (reflecting any global.json): Version: 3.0.100-preview5-011568 Commit: b487ff10aa

Runtime Environment: OS Name: Windows OS Version: 10.0.18362 OS Platform: Windows RID: win10-x64 Base Path: c:\program files\dotnet\sdk\3.0.100-preview5-011568\

Host (useful for support): Version: 3.0.0-preview5-27626-15 Commit: 61f30f5a23

.NET Core SDKs installed: 2.1.500 [c:\program files\dotnet\sdk] 2.1.502 [c:\program files\dotnet\sdk] 2.1.504 [c:\program files\dotnet\sdk] 2.1.600-preview-009426 [c:\program files\dotnet\sdk] 2.1.600-preview-009472 [c:\program files\dotnet\sdk] 2.1.600-preview-009497 [c:\program files\dotnet\sdk] 2.1.600 [c:\program files\dotnet\sdk] 2.1.602 [c:\program files\dotnet\sdk] 2.1.700-preview-009597 [c:\program files\dotnet\sdk] 2.1.700-preview-009618 [c:\program files\dotnet\sdk] 2.1.800-preview-009677 [c:\program files\dotnet\sdk] 2.2.101 [c:\program files\dotnet\sdk] 2.2.300-preview-010046 [c:\program files\dotnet\sdk] 2.2.300-preview-010067 [c:\program files\dotnet\sdk] 2.2.400-preview-010195 [c:\program files\dotnet\sdk] 3.0.100-preview5-011568 [c:\program files\dotnet\sdk]

.NET Core runtimes installed: Microsoft.AspNetCore.All 2.1.6 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.1.7 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.1.8 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.1.9 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.1.11 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.2.0 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.2.3 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.All 2.2.5 [c:\program files\dotnet\shared\Microsoft.AspNetCore.All] Microsoft.AspNetCore.App 2.1.6 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.1.7 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.1.8 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.1.9 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.1.11 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.2.0 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.2.3 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 2.2.5 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.AspNetCore.App 3.0.0-preview5-19227-01 [c:\program files\dotnet\shared\Microsoft.AspNetCore.App] Microsoft.NETCore.App 2.1.6 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.1.7 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.1.8 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.1.9 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.1.11 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.2.0 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.2.3 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 2.2.5 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.NETCore.App 3.0.0-preview5-27626-15 [c:\program files\dotnet\shared\Microsoft.NETCore.App] Microsoft.WindowsDesktop.App 3.0.0-preview5-27626-15 [c:\program files\dotnet\shared\Microsoft.WindowsDesktop.App]

该提问来源于开源项目:dotnet/sdk

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39996035 weixin_39996035 4月前

    The -d option enables diagnostics for the command resolution of the CLI. Say, for project tools and global tools.

    So, in a sense, it offers diagnostics for the core of the CLI itself. Beyond that, most commands use '-v, --verbosity` to mean the output level for that command.

    In the particular case of dotnet new, I am not sure what is their diagnostics flag. cc to provide more information on that.

    点赞 评论 复制链接分享
  • weixin_39768695 weixin_39768695 4月前

    For template installation issues, you could try either or both of --trace:authoring or --trace:install, like this: dotnet new -i c:\path\to\nupkg --trace:authoring --trace:install The output from these flags is not as robust as it could be, but you may find it useful.

    If this doesn't help identify the install problem, I can work with you to figure it out.

    点赞 评论 复制链接分享
  • weixin_39626089 weixin_39626089 4月前

    I tried both --trace:authoring --trace:install and each one individually and there is no difference in output.

    can you ping me on MS Teams so we can chat? alias is adegeo

    点赞 评论 复制链接分享
  • weixin_39996035 weixin_39996035 4月前

    have you folks figured out the issue here?

    点赞 评论 复制链接分享
  • weixin_39626089 weixin_39626089 4月前

    I think this can be closed. I got my issue solved that led me to looking at diagnostic stuff.

    However, I think dotnet needs a better experience around enabling debug output so people know what is going on while running commands. It doesn't seem that this experience really exists currently? Nor do commands implement this the same. Sometimes it's --trace and sometimes it's -v but this basic concept should be unified to all commands.

    点赞 评论 复制链接分享

相关推荐