weixin_39931146
2020-12-26 22:27 阅读 1

Package jbuild-create-templates.v0.1.0

jbuild-create-templates.v0.1.0

Package that provides templates for jbuild-create

Package that provides templates for jbuild-create. This is useless on its own and is just a dependency for jbuild-create. You should install that package instead.

  • Homepage: https://github.com/sgpthomas/jbuild-create-templates
  • Source repo: git.com:sgpthomas/jbuild-create-templates.git
  • Bug tracker: https://github.com/sgpthomas/jbuild-create-templates

:camel: Pull-request generated by opam-publish v0.3.5

该提问来源于开源项目:ocaml/opam-repository

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

6条回答 默认 最新

  • weixin_39862899 weixin_39862899 2020-12-26 22:27
    :white_check_mark: All lint checks passed 5207eda377d875339dbdbc15a1b5e1f82e99aced
    • These packages passed lint tests: jbuild-create-templates.v0.1.0
    :white_check_mark: Installability check (8613 → 8614)
    • new installable packages (1): jbuild-create-templates.v0.1.0
    点赞 评论 复制链接分享
  • weixin_39671509 weixin_39671509 2020-12-26 22:27

    Your package seems really broken. Looking at you source code

    make
    installs some static files in
    ~/.local/...
    (if you can avoid that it would be nice) and your uninstall phase just don't exist + you try to use ocamlfind where you don't install any libraries ?

    Could you expand a bit on the goal of this package ?

    点赞 评论 复制链接分享
  • weixin_39931146 weixin_39931146 2020-12-26 22:27

    This package was mainly to test how opam packaging works, and to serve as a dependency for this project: https://github.com/sgpthomas/jbuild-create. Its a simple project to automatically create a simple jbuild project. It copies files from template files located ~/.local/share/jbuild-create/templates. What is the proper way to accomplish something like this?

    点赞 评论 复制链接分享
  • weixin_39839478 weixin_39839478 2020-12-26 22:27

    You can use the share folder in your opam environment, like merlin does: https://github.com/ocaml/merlin/blob/master/merlin.install#L6

    That would also be better as multiplatform approach and it would work properly when opam removes the package

    点赞 评论 复制链接分享
  • weixin_39671509 weixin_39671509 2020-12-26 22:27

    Also, please do not use the

    v
    prefix in your version numbers. This is a hack used only for the janestreet package because they changed their version scheme.

    More on that in: https://github.com/dbuenzli/topkg/issues/122

    点赞 评论 复制链接分享
  • weixin_39671509 weixin_39671509 2020-12-26 22:27

    I'm going to close this. Feel free to reopen it/open another PR when you are ready.

    点赞 评论 复制链接分享

相关推荐