weixin_39765840
weixin_39765840
2020-12-27 12:28

PROBLEM NUGET VISUAL STUDIO XAMARIN.FORMS

Hello,

I have a visual studio project (Xamarin.Forms + PRISM)

PCL Have this configuration (standard configuration when i add new project Xamarin.form(portable)): - TargetFrameworkVersion : v4.5 - TargetFrameworkProfile: Profile259

When I add the package ACR.UserDialog #(6.3.6) from nuget, the system print one error:

Could not install package 'Splat 1.6.2'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.5,Profile=Profile259', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author

Any Solution?

该提问来源于开源项目:aritchie/userdialogs

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39765840 weixin_39765840 4月前

    Have you these framwork?

    image

    点赞 评论 复制链接分享
  • weixin_39620662 weixin_39620662 4月前

    I'm not sure why you're asking me this... but yes. The issue you are having won't have anything to do with what you're showing me. If you want, you can send me your project and I'll take a look. I installed 6.3.6 into a fresh project this morning without issue. There is either something with your VS/nuget package manager or your project.

    点赞 评论 复制链接分享
  • weixin_39765840 weixin_39765840 4月前

    it's all OK. It was a caching problem NuGet :-(

    点赞 评论 复制链接分享
  • weixin_39620662 weixin_39620662 4月前

    The PCL profile this library supports is 259. I believe the profile the default forms project sets up is 111. Change your profile accordingly.

    点赞 评论 复制链接分享
  • weixin_39765840 weixin_39765840 4月前

    My Profile is 259

    点赞 评论 复制链接分享
  • weixin_39620662 weixin_39620662 4月前

    I don't know what to tell you then. I have this installed in a ton of PCL projects right now that are 259 which also includes splat.

    点赞 评论 复制链接分享

相关推荐