weixin_39767887
weixin_39767887
2020-12-27 14:34

Error 1008 from eBay API

When making a LMS active inventory (download) request, I get this issue:


 xml version="1.0" encoding="utf-8"?>
<bulkdataexchangeresponses xmlns="urn:ebay:apis:eBLBaseComponents">
    <activeinventoryreport>
        <ack>Failure</ack>
        <errors>
            <shortmessage>Could not get item information right now,Please try again</shortmessage>
            <longmessage>ItemIds: [XXXX, XXXX]</longmessage>
            <errorcode>1008</errorcode>
            <severitycode>LMS.ERROR</severitycode>
            <errorclassification>ParsingError</errorclassification>
        </errors>
        <ack>Failure</ack>
        <errors>
            <shortmessage>LMS Internal Error</shortmessage>
            <longmessage>LMS Internal Error</longmessage>
            <errorcode>1008</errorcode>
            <severitycode>LMS.ERROR</severitycode>
            <errorclassification>InternalError</errorclassification>
        </errors>

    </activeinventoryreport>
</bulkdataexchangeresponses>

Is this a sandbox issue? Or an error on my part? The code is from the ebay-sdk-examples repository with nothing changed.

Sometimes it returns successfully but with no items in the inventory report.

该提问来源于开源项目:davidtsadler/ebay-sdk-php

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

7条回答

  • weixin_39599654 weixin_39599654 3月前

    May be issue with sandbox as it looks like someone else is having the same problem. I'll keep an eye on the API status page to see if anythings reported before I'll close this issue.

    点赞 评论 复制链接分享
  • weixin_39767887 weixin_39767887 3月前

    I'm about to submit a help ticket. What eBay API version is the ebay-sdk-examples using?

    点赞 评论 复制链接分享
  • weixin_39599654 weixin_39599654 3月前

    The LMS examples don't specify an API version in the request as this value is optional. But it is easy to do.

     php
    $exchangeService = $sdk->createBulkDataExchange([
        'apiVersion' => '1.5.0'
    ]);
    $transferService = $sdk->createFileTransfer([
        'apiVersion' => '1.1.0'
    ]);
    
    点赞 评论 复制链接分享
  • weixin_39767887 weixin_39767887 3月前

    Hey, I've been using a different API call other than the API request and it's been working fine, I don't know if the original issue was fixed but it's no longer needed. You have made an excellent API (the code-level documentation is amazing) though, thank you.

    点赞 评论 复制链接分享
  • weixin_39965881 weixin_39965881 3月前

    it would be nice to know which alternative API you used

    点赞 评论 复制链接分享
  • weixin_39926678 weixin_39926678 3月前

    Agreed which alternative API you used? I'm having same error utilizing the eBay sandbox. btw excellent eBay SDK and MUCH appreciated

    点赞 评论 复制链接分享
  • weixin_39926678 weixin_39926678 3月前

    lol solved by using eBay Production. seems the sandbox isn't always maintained like it should be. 5 years ago had a similar challenge with eBay sandbox with getsellerlist.

    点赞 评论 复制链接分享