weixin_39929813
weixin_39929813
2020-12-28 15:28

Authentication window not popping

Hello I'm French so sorry in advance for my bad English. So I had EDMC since few years ago and everything worked perfectly with the "identity" panel where you were able to type manually your credentials but now apparently this is a popup window wich will ask you for an authentication in Frontier website but I never seen this window because it is not popping at all ! I'll put a screenshot of what EDMC is showing me. Also I have the latest version of EDMC and my Frontier account is not linked to my Steam one.

I tried to :

  • Uninstalling and re-installing EDMC about 10 times
  • Change the default browser between Chrome, Firefox, Edge and Opera
  • Delete all EDMC related folders in the PC
  • Check the authorised applications in my Frontier account but EDMC isn't here
  • Run EDMC as an administrator, with compatibility mode for W7 and W8
  • Check the 3 file path in the EDMC settings
  • Authorise EDMC in Windows Defender
  • Clicking on File>Status return "Error: Invalid Credentials"
  • Clicking on File>Save Raw Data... does absolutely nothing
  • I also tested EDMC while in Elite Dangerous but it didn't work
  • And I can't click on "Update"

Can anybody help please ?

PS : I saw that there are 4 ohers related issues but theses don't resolve my issue.

EDMarketConnector.log

what_edmc_is_showing_me

该提问来源于开源项目:EDCD/EDMarketConnector

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

8条回答

  • weixin_39967120 weixin_39967120 4月前

    -o I did take a look at the portal. Sadly, there was no EDMC in Authorized Applications.

    点赞 评论 复制链接分享
  • weixin_39929813 weixin_39929813 4月前

    So I managed to find the problem and fix it : in File>Settings>Configuration the "E:D journal file location" was not set properly by my fault, so I clicked on "Default" and then "OK" and instantly the app opened the corresponding frontier authentication window then I was able to connect and approve EDMC. I think EDMC will not open the window until this path is correct. Usually the path is : "C:\Users\YOURNAME\Saved Games\Frontier Developments\Elite Dangerous". Remember also to de-authorize EDMC in your frontier account, as -o said.

    点赞 评论 复制链接分享
  • weixin_39542043 weixin_39542043 4月前

    Hello, which web browser do you use?

    点赞 评论 复制链接分享
  • weixin_39883286 weixin_39883286 4月前

    Same issue for me I'm using Chrome 80.0.3987.132 (Official Build) (64-bit)

    点赞 评论 复制链接分享
  • weixin_39929813 weixin_39929813 4月前

    Hello, which web browser do you use?

    Hello Doc, I think if you read again my issue then you will have your answer.

    点赞 评论 复制链接分享
  • weixin_39929813 weixin_39929813 4月前

    So I switched to EDDI and it's working perfectly and has more features, I let this issue opened if Marginal wants to fix it, I think EDMC should have a button to login manually just like EDDI instead of a script wich will not always open the authentication window automatically. (PS : sorry for my bad English, I'm French)

    点赞 评论 复制链接分享
  • weixin_39967120 weixin_39967120 4月前

    Same issue persisting here. After reinstalling several times, I can't get the login window to appear on my end as well. Has anyone found a fix for this?

    点赞 评论 复制链接分享
  • weixin_39815925 weixin_39815925 4月前

    Hey there, Had something similar sorted out a few days ago, the reason why the authentication window does not appear is that the application is still authorized in your Frontier account. Go there https://user.frontierstore.net/, authenticate with your Frontier account, go to "Authorized applications" and deauthorize the EDMC app if it is present. Next time you open EDMC, you should get the authentication page… Hope this helps!

    点赞 评论 复制链接分享

相关推荐