weixin_39869043
weixin_39869043
2020-12-30 04:48

dnsmasq fails to start on raspbian with dnsmasq 2.7.6

In raising this issue, I confirm the following: {please fill the checkboxes, e.g: [X]}

How familiar are you with the the source code relevant to this issue?:

1

Expected behaviour:

dnsmasq starts and DNS resolution is available.

Actual behaviour:

dnsmasq fails to start and DNS resolution is unavailable.

Steps to reproduce:

Switch to development branch and update.

Debug token provided by uploading pihole -d log:

5n64o3tq1c

Troubleshooting undertaken, and/or other relevant information:

I updated to the development branch to attempt to resolve an unrelated issue and found dnsmasq subsequently stayed down. The error received is below:

Jan 09 20:28:01 marida dnsmasq[17967]: dnsmasq: bad option at line 47 of /etc/dnsmasq.d/01-pihole.conf Jan 09 20:28:01 marida systemd[1]: dnsmasq.service: Control process exited, code=exited status=1 Jan 09 20:28:01 marida systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.

I had to disable FTL, enable dnsmasq, switch back to ftl master, then toggle dnsmasq/FTL again for things to work.

It looks like this is coming from #2570 if I had to guess. I am on dnsmasq 2.7.6 (which raspbian stretch reports as "latest"), and dhcp-name-match wasn't released until ~2.8, but I thought FTL was supposed to replace dnsmasq?

I am unsure if this breaking change was intended or not, but felt it warranted a report as I don't see documentation to the contrary.

该提问来源于开源项目:pi-hole/FTL

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

11条回答

  • weixin_39869043 weixin_39869043 4月前

    this appears to continue to be an issue for me. Whenever I update, 01-pihole.conf is overwritten and dhcp-name-match is added back. Whenever that is enabled I receive the error above again that implies my version of dnsmasq doesn't support that option. Thoughts? Thanks!!

    点赞 评论 复制链接分享
  • weixin_39670267 weixin_39670267 4月前

    Run pihole -d for a debug token. The development and v4.2 release candidate versions of FTL use dnsmasq v2.80, which supports this option.

    点赞 评论 复制链接分享
  • weixin_39869043 weixin_39869043 4月前

    so is dnsmasq v2.8 a requirement then? This seems like a breaking change considering. I'm running OOTB raspbian stretch.

    Here's the debug token as requested: gw4xhum0kj

    Thanks!

    点赞 评论 复制链接分享
  • weixin_39670267 weixin_39670267 4月前

    This is not a breaking change, because FTL ships v2.80. We can not support users using any version of dnsmasq. FTL embeds dnsmasq, so you do not need the standalone one. You are using the development version of core and web, but did not update FTL to development.

    点赞 评论 复制链接分享
  • weixin_39869043 weixin_39869043 4月前

    it was before the issue, but I reverted it because of the issue, and now I'm experiencing this issue while not on development. So I'm trying to understand what the path to resolution is for me. Can you help me understand? Are you saying I need to have all components on dev or none? Like having core or web on dev is somehow bringing in this FTL config option early?

    点赞 评论 复制链接分享
  • weixin_39670267 weixin_39670267 4月前

    According to your debug log, you have core and web on the development branches while FTL is on master.

    
    *** [ DIAGNOSING ]: Core version
    [i] Core: v4.1.1 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
    [i] Branch: development (https://discourse.pi-hole.net/t/the-pihole-command-with-examples/738#checkout)
    [i] Commit: v4.1.1-31-gf7ca74c
    
    *** [ DIAGNOSING ]: Web version
    [i] Web: v4.1 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
    [i] Branch: devel (https://discourse.pi-hole.net/t/the-pihole-command-with-examples/738#checkout)
    [i] Commit: v4.1-35-ga2615c8c
    
    *** [ DIAGNOSING ]: FTL version
    [✓] FTL: v4.1.2
    

    To avoid possible errors like the one you found, the branches of all three components must match. If you want to stay on development, update FTL to development. If you want to go back to master, downgrade core and web to master.

    点赞 评论 复制链接分享
  • weixin_39869043 weixin_39869043 4月前

    ah that makes sense, switched the rest of the components over and no more error. Thanks!!

    点赞 评论 复制链接分享
  • weixin_39796363 weixin_39796363 4月前

    With this version of Pi-Hole, dnsmasq does not run as a separate process. The dnsmasq code is embedded in pihole-FTL. What are the contents of /etc/dnsmasq.d/o1-pihole.conf (specifically line 47)?

    点赞 评论 复制链接分享
  • weixin_39869043 weixin_39869043 4月前

    -pihole Line 47 contains the dhcp-name-match as I tried to imply at the bottom of my post. I had originally thought it matched exactly what is in the PR I mentioned, but I just triple checked and see now that is not the case. Thanks for the follow up!

    点赞 评论 复制链接分享
  • weixin_39900023 weixin_39900023 4月前

    Closing as resolved. It was a typo.

    点赞 评论 复制链接分享
  • weixin_39869043 weixin_39869043 4月前

    Thanks!!

    点赞 评论 复制链接分享

相关推荐