weixin_39793434
weixin_39793434
2020-12-30 06:48

Issue with the AppImage in Ubuntu 17.10

Trying to run the AppImage in 64-bit 17.10 gets me the following error:

"$ ./taisei-1.1+195.g1a45593-Build228.1.glibc2.14-x86_64.AppImage amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-13) amdgpu: amdgpu_device_initialize failed. do_winsys_init: DRM version is 3.18.0 but this driver is only compatible with 2.12.0 (kernel 3.2) or later. 1076 W: load_resource(): Failed to locate bgm 'menu' 1076 W: parse_keyvalue_file_cb(): VFS error: Node 'res/shader/postprocess.conf' does not exist 1076 W: progress_load(): Couldn't open the progress file: SDL error: Couldn't open /home/desum/.local/share/taisei/progress.dat 1085 W: get_resource(): bgm 'menu' was not preloaded 1085 W: load_resource(): Failed to locate bgm 'menu' 1085 W: start_bgm(): BGM 'menu' does not exist"

Happens with or without the Padoka PPA. Worst bit is that all eight of my CPU cores shoot up to 100% and the only fix is a reboot

该提问来源于开源项目:taisei-project/taisei

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

12条回答

  • weixin_39878989 weixin_39878989 4月前

    Building proper packages for half a dozen distros and their various releases is in fact much easier than producing a single working bundle. So we’re doing just that (to the extent possible with OBS).

    It’s a little counter-intuitive because not having to do this is one of the major selling points for all those app bundle techniques. Guess they’re just another solution looking for a problem, and about as well-engineered as you’d expect from people with a background in web and/or Windows development.

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 4月前

    Hardware: AMD FX 8350 RX 480 with Mesa

    OS: Ubuntu Mate 17.10 AMD64

    点赞 评论 复制链接分享
  • weixin_39878989 weixin_39878989 4月前
    
    amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-13)
    amdgpu: amdgpu_device_initialize failed.
    do_winsys_init: DRM version is 3.18.0 but this driver is only compatible with 2.12.0 (kernel 3.2) or later.
    

    That is almost guaranteed to be a driver issue, and it looks like your system is broken.

    点赞 评论 复制链接分享
  • weixin_40009099 weixin_40009099 4月前

    Does OpenGL work at all? Try glxgears, glxinfo, or another GL-based game maybe.

    点赞 评论 复制链接分享
  • weixin_39878989 weixin_39878989 4月前

    Maybe this is some Wayland issue? Does Ubuntu MATE also use Wayland by default? I could imagine something like SDL trying to use the DRM backend because Wayland failed…

    点赞 评论 复制链接分享
  • weixin_39878989 weixin_39878989 4月前

    https://www.reddit.com/r/linux/comments/4jc6zh/amd_unleashes_initial_amdgpu_driver_support_for/d35sohx/

    So yeah, this looks like Ubuntu MATE ships with a broken driver setup (wouldn’t put it past them), unless you’ve done and ruined it yourself.

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 4月前

    driver issue

    Doesn't seem to be the case; OpenGL works fine. And this happens with both the default Mesa drivers and the Padoka PPA. Pretty much every Steam game works for me too.

    I tried the .deb installer and that works too with no error other than the missing bgm (which I assume hasn't been added yet):

    desum-MS-7992:~/Desktop$ taisei 315 W: load_resource(): Failed to locate bgm 'menu' 315 W: parse_keyvalue_file_cb(): VFS error: Node 'res/shader/postprocess.conf' does not exist 315 W: get_resource(): bgm 'menu' was not preloaded 315 W: load_resource(): Failed to locate bgm 'menu' 315 W: start_bgm(): BGM 'menu' does not exist

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 4月前

    As for Wayland, as far as I know, other than the GTK3 port, no real work on Mate/Wayland has happened yet.

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 4月前

    Just tried the AppImage in Manjaro on the same box and I get a similar error: [manjaro-mate Downloads]$ ./taisei-1.1+198.gcdb621e-Build230.1.glibc2.14-x86_64.AppImage amdgpu: amdgpu_device_initialize failed. do_winsys_init: DRM version is 3.8.0 but this driver is only compatible with 2.12.0 (kernel 3.2) or later. 2807 W: load_resource(): Failed to locate bgm 'menu' 2815 W: parse_keyvalue_file_cb(): VFS error: Node 'res/shader/postprocess.conf' does not exist 2816 W: progress_load(): Couldn't open the progress file: SDL error: Couldn't open /home/manjaro/.local/share/taisei/progress.dat 2817 W: get_resource(): bgm 'menu' was not preloaded 2818 W: load_resource(): Failed to locate bgm 'menu' 2818 W: start_bgm(): BGM 'menu' does not exist

    点赞 评论 复制链接分享
  • weixin_39793434 weixin_39793434 4月前

    I also tested the version from the AUR, and that worked, albit it with a couple minor errors:

    manjaro-mate Desktop]$ taisei 859 W: png_warning_handler(): PNG warning: iCCP: known incorrect sRGB profile 1830 W: load_resource(): Failed to locate bgm 'bgm_menu' 1830 W: parse_keyvalue_file_cb(): VFS error: Node 'res/shader/postprocess.conf' does not exist 1830 W: progress_load(): Couldn't open the progress file: SDL error: Couldn't open /home/manjaro/.local/share/taisei/progress.dat 1831 W: get_resource(): bgm 'bgm_menu' was not preloaded 1831 W: load_resource(): Failed to locate bgm 'bgm_menu' 1831 W: start_bgm(): BGM 'bgm_menu' does not exist

    点赞 评论 复制链接分享
  • weixin_39854369 weixin_39854369 4月前

    with one of my appimage app, i've found that it need libgconf to get it loaded.

    点赞 评论 复制链接分享
  • weixin_39974409 weixin_39974409 4月前

    With AppImage being so strange and that GL problem being only specific to AppImage, we decided to drop it and just supply statically linked binaries as a “portable across linux” thing in the future. Much more predictable and probably less effort to get right.

    Thanks for your effort -Dolus and though :)

    点赞 评论 复制链接分享

相关推荐