weixin_39789979
weixin_39789979
2021-01-01 00:06

launcher Dosent work on OS X

该提问来源于开源项目:Slowpoke101/FTBLaunch

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

17条回答

  • weixin_39735288 weixin_39735288 4月前

    To Java 7

    点赞 评论 复制链接分享
  • weixin_39604280 weixin_39604280 4月前

    actually, i have Java 7 and the launcher crashes right when it opens the instance right at the black screen before the mojang logo; OSX, by the way

    点赞 评论 复制链接分享
  • weixin_39737947 weixin_39737947 4月前

    Is there anything specific to Java 7 that is required for the launcher? I managed to get it to compile and run under java version "1.6.0_37" on OSX 10.6.8 but have not tested everything.

    点赞 评论 复制链接分享
  • weixin_39734048 weixin_39734048 4月前

    You cannot update to Java 7 under mac os x 10.6. Is there any way to make it work under Java 6?

    点赞 评论 复制链接分享
  • weixin_39904587 weixin_39904587 4月前

    hello i have updated to java version 7 update 9 and am having the same problem as "MrTJP" where it goes to the black screen then closes everything that it had opened (the launcher, console and instance) and wondering if there are any solutions.

    点赞 评论 复制链接分享
  • weixin_39735288 weixin_39735288 4月前

    There is a version of the launcher that Direwolf20 has just tweeted that was built for java 6

    点赞 评论 复制链接分享
  • weixin_39630106 weixin_39630106 4月前

    It works for me. You need to follow the instructions on the FAQ. You do NOT simply double click it. Open terminal (in /Applications/Utilities/Terminal), type cd (Stands for change directory) and drag in the folder containing the ftb jar which should look something like this. cd /Where/it/is/located Press enter then type java -jar nameOfLauncher.jar and it will work correctly (at least for me)

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 4月前

    thanks the one that DW20 worked. :)

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 4月前

    and now its crashing when the world loads

    点赞 评论 复制链接分享
  • weixin_39630106 weixin_39630106 4月前

    I created an applescript to make it easy if anyone is still having trouble http://forum.feed-the-beast.com/index.php?threads/.438

    点赞 评论 复制链接分享
  • weixin_39969143 weixin_39969143 4月前

    opening the file in terminal worked no idea why but it works :D

    点赞 评论 复制链接分享
  • weixin_39932455 weixin_39932455 4月前

    I run Mac OSX (Mountain Lion) and the launcher opens fine for me no terminal needed.

    点赞 评论 复制链接分享
  • weixin_39843338 weixin_39843338 4月前

    i can open find in finder (no terminal needed) however i'm getting a out of memory error after a few seconds of playing. also getting error if i use terminal

    点赞 评论 复制链接分享
  • weixin_39904587 weixin_39904587 4月前

    TheSandwichMakr i tried to run the applescript but it says "You can't open the application Feed the Beast because the Classic environment is no longer supported." any ideas please?

    点赞 评论 复制链接分享
  • weixin_39630106 weixin_39630106 4月前

    What version of OS X are you using raggedreece?

    点赞 评论 复制链接分享
  • weixin_39735288 weixin_39735288 4月前

    You need to update your Java.

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 4月前

    to what version

    点赞 评论 复制链接分享

相关推荐