weixin_39639381
weixin_39639381
2021-01-01 05:11

This don't builds anymore on current node ? What is the last supportet node version

I found out that this lib is not working on current nodejs versions what is the last supportet version?

该提问来源于开源项目:mafintosh/fuse-bindings

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

18条回答

  • weixin_39639381 weixin_39639381 4月前

    i will still publish node-fuse-bindings with some extra stuff it will simply relay on 's version till the fuse-nativ is ready and working better then the other version.

    i will simply contribute back to what ever is used on my backend side maybe node will evolve also.

    so its not so importent that anything gets released soon the current situation already forced me to use go as a coding lang as it got the most current fuse support. I need now to reevaluate if we can offer node support again.

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    Can you merge too all the open pull-requests? This would greatly helps to unify efforts, there are no so much forks and would clean-up things...

    点赞 评论 复制链接分享
  • weixin_39639381 weixin_39639381 4月前

    i have everthing in https://github.com/direktspeed/node-fuse-bindings exempt the 2 ts pull requests as i am not a typescript use you can simply install it via

    
    npm i -s node-fuse-bindings
    
    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    i have everthing in direktspeed/node-fuse-bindings exempt the 2 ts pull requests as i am not a typescript use you can simply install it via

    Have you implemented them yourself, copy the code, or done merging of the code commits?

    点赞 评论 复制链接分享
  • weixin_39785165 weixin_39785165 4月前

    Builds fine with 10.17 but not with 11.x.

    点赞 评论 复制链接分享
  • weixin_39996141 weixin_39996141 4月前

    you'll probably find everything works really nice with 8. That's around when this died.

    点赞 评论 复制链接分享
  • weixin_39639381 weixin_39639381 4月前

    Thanks for the feedback I think we should line that out in the README and attract new Maintainers that will update nan and the bindings.

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    Thanks for the feedback I think we should line that out in the README and attract new Maintainers that will update nan and the bindings.

    And port to libfuse 3... I think did some improvements towards this in the past in https://github.com/javiergarmon/fuse3-bindings.

    点赞 评论 复制链接分享
  • weixin_39756540 weixin_39756540 4月前

    I recently opened a pull-request with all updates required to use that with node 12/13. https://github.com/noguilty4you/fuse-bindings/tree/node-13-adaption

    Unfortunately mr doesn't handle the PR's by now.

    Tests passed and one of my customers uses it in production already.

    点赞 评论 复制链接分享
  • weixin_39639381 weixin_39639381 4月前

    we should simply publish your maintained version if you like? We Should rename it a bit to make clear that yoru bindings are the current maintained once maybe is sick or dead i don't know him but i will take your version into my organisation and line out that it is the current maintained version i will also add you as maintainer and i will do automation for npm publishing thanks a lot for your effort

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    maybe is sick or dead i don't know him

    The best way to say that is to check its github profile activity, and no, he's not dead :-) The last news I had from him is that he's busy with https://twitter.com/dat_project

    点赞 评论 复制链接分享
  • weixin_39616477 weixin_39616477 4月前

    The rumours of my death are greatly exaggerated

    is fuse3 supported on osx?

    Btw we’re about to release fuse-native, https://github.com/fuse-friends/fuse-native where we re-engineered the impl using napi and multithread support.

    If anyone is interested in helping maintain this feel free to reach out.

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    The rumours of my death are greatly exaggerated

    Lol :-P

    is fuse3 supported on osx?

    No idea, not an OSX user since 10 years ago... but a quick search says "no", only fuse2 :-(

    Btw we’re about to release fuse-native, fuse-friends/fuse-native where we re-engineered the impl using napi and multithread support.

    Nice! Is it based on fuse3? :-)

    点赞 评论 复制链接分享
  • weixin_39616477 weixin_39616477 4月前

    no fuse2.7 i think as that afaik is the only one ported to osx still. We very very very much would like to get 3 in there but osx support is still more important for our usecases.

    You prob easily fork and switch to fuse3 tho as it’s mostly just “glue” code from c to js

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    We very very very much would like to get 3 in there but osx support is still more important for our usecases.

    Ok, I totally understand.

    You prob easily fork and switch to fuse3 tho as it’s mostly just “glue” code from c to js

    Are you talking about fuse-native, or this one? For this one, did some progress, maybe we could start working on a new v3 branch or in another repo until OSX support appears... What do you recomends?

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    According to https://github.com/osxfuse/osxfuse/issues/390, osxfuse is based in fuse 2.9.7, and although they would like to upgrade to libfuse 3... seems the project is dead, with no commits in 2 years :-(

    点赞 评论 复制链接分享
  • weixin_39756540 weixin_39756540 4月前

    we should simply publish your maintained version if you like? We Should rename it a bit to make clear that yoru bindings are the current maintained once maybe is sick or dead i don't know him but i will take your version into my organisation and line out that it is the current maintained version i will also add you as maintainer and i will do automation for npm publishing thanks a lot for your effort

    -dspeed, if will release the fuse-native module soon, maybe we shouldn't create a 999,999,999th npm package? What do u think about it?

    点赞 评论 复制链接分享
  • weixin_39874196 weixin_39874196 4月前

    -dspeed, if will release the fuse-native module soon, maybe we shouldn't create a 999,999,999th npm package? What do u think about it?

    I agree, we should concentrate efforts.

    点赞 评论 复制链接分享

相关推荐