weixin_39637571
weixin_39637571
2021-01-06 09:59

change win32 dependence from pypiwin32 to pywin32

Please consider changing the win32 dependency from pipywin32 to pywin32.

I was researching TUI libraries, especially asciimatics, after learning about it from local peer. Part of that was looking at the dependencies.

The pypiwin32 dependency is declared here: https://github.com/peterbrittain/asciimatics/blob/master/setup.py#L73. This appears to date back to 2015.

Googling this dependency to learn about it, I think it may be preferable to change this to pywin32. Googling showed:

  • pypi.org has Feb 26, 2018 as latest for pypiwin32.  pypi.org has Jun 13, 2020 as latest for pywin32.

  • Looks like circa 2016 pypiwin32 was an offered repackaging of pywin32 to use wheels.  [1]

  • Looking at pypi today for pywin32, it appears to use only wheels.  [2]

[1] https://mail.python.org/pipermail/python-win32/2016-October/013786.html [2] https://pypi.org/project/pywin32/#files

I suspect pypiwin32 was a workaround for a problem that no longer exists. If that is so, then replace the pypiwin32 dependency in setup.py with pywin32.

One workaround may be to wrangle pip to install asciimatics without installing pypiwin32. (99% sure this can be done, but need to look it up in the pip documentation.)

Related but similarly dated # 111.

Thanks!

该提问来源于开源项目:peterbrittain/asciimatics

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

6条回答