weixin_39899244
weixin_39899244
2021-01-06 17:25

Bridge VLAN Network Issue

I am having issue with a guest VM connecting to Bridge VLAN network interfaces created in Kimchi on a Ubuntu 16.04 x64 server.

I tested my VLAN successfully on ethernet wire prior to hookup to KVM/Kimchi host. I made my bridged network with VLAN number specified. I then connected a new interfaces to VM. Interface is setup to connect to bridge created. However interface is unable to get DHCP IP.

I created VLAN 10 specified below outside of Kimchi, it works fine and it is how I connect to host currently. You can find my /etc/network/interfaces file below, bridges listed below where added by Kimchi. I have rebooted Host and VM a few times. What else can I try to fix this issue?

auto lo
iface lo inet loopback

auto enp11s0
iface enp11s0 inet manual

auto enp11s0.10
iface enp11s0.10 inet dhcp
   vlan-raw-device enp11s0

auto kbenp11s0-2
iface kbenp11s0-2 inet manual
   bridge_ports enp11s0.2
iface enp11s0.2 inet manual
   vlan_raw_device enp11s0

auto kbenp11s0-15
iface kbenp11s0-15 inet manual
   bridge_ports enp11s0.15
iface enp11s0.15 inet manual
   vlan_raw_device enp11s0

该提问来源于开源项目:kimchi-project/kimchi

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39899244 weixin_39899244 4月前

    Quick update. I have a implemented a workaround. I separated the VLAN configurations from the bridge configuration and I am able to pass network to the guests. Below I have demonstrated changes to /etc/network/interface file from Kimchi then changes I implemented to work for my setup. DHCP has to be specified at the Bridge level to ensure Address Space show up in Virtualization tab in Kimchi

    Kimchi Changes

    
    
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    source /etc/network/interfaces.d/*
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto enp11s0
    iface enp11s0 inet manual
    
    auto kbenp11s0-15
    iface kbenp11s0-15 inet manual
       bridge_ports enp11s0.15
    iface enp11s0.15 inet manual
       vlan_raw_device enp11s0
    auto kbenp11s0-10
    iface kbenp11s0-10 inet manual
       bridge_ports enp11s0.10
    iface enp11s0.10 inet manual
       vlan_raw_device enp11s0
    

    My Changes

    
    
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    source /etc/network/interfaces.d/*
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto enp11s0
    iface enp11s0 inet manual
    
    auto kbenp11s0-15
    iface kbenp11s0-15 inet dhcp
       bridge_ports enp11s0.15
    
    auto enp11s0.15
    iface enp11s0.15 inet manual
       vlan_raw_device enp11s0
    
    allow-hotplug kbenp11s0-2
    iface kbenp11s0-2 inet dhcp
       bridge_ports enp11s0.2
    
    auto enp11s0.2
    iface enp11s0.2 inet manual
       vlan_raw_device enp11s0
    
    auto kbenp11s0-10
    iface kbenp11s0-10 inet dhcp
       bridge_ports enp11s0.10
    
    auto enp11s0.10
    iface enp11s0.10 inet manual
       vlan_raw_device enp11s0
    
    
    点赞 评论 复制链接分享
  • weixin_39682940 weixin_39682940 4月前

    interesting. We'll evaluate if this is something that needs fixing in Kimchi itself or if it was something that was required for your specific setup.

    Thanks!

    点赞 评论 复制链接分享
  • weixin_39589394 weixin_39589394 4月前

    I want to confirm this bug. I recently started using kimchi and it fails to bring up a vlan bridge properly on its own. While kimchi does all the work in /etc/network/interfaces it forgets to add the line auto <iface>.<vlan> to bring the vlan subifc up. You can do manually your ifup <iface>.<vlan> to setup the interface, which even is added automatically to the kvm-bridge. However you need the line above to make the config persistent after reboots

    OS: Ubuntu 16.04.3 Kimchi: 2.5.0

    点赞 评论 复制链接分享
  • weixin_39821605 weixin_39821605 4月前

    if you plan to make a bridge network interface on kimchi using CentOS 7 use the following steps

    to enable the brdige interface you need to disable NetworkManager

    sudo systemctl disable NetworkManager.service sudo systemctl stop NetworkManager.service

    after stopping the NetworkManager remote terminal will disconnect

    go to check your network interface

    cd /etc/sysconfig/network-scripts/

    ls

    you can see the bridge interface name could be something like "kbeno1" type "nmtui" to access the network interface via graphic interface

    Select kbeno1 bridge interface and edit it the eno1 interface is already slave and bridge is master scroll down fine the ipv4 settings -> go to ip setting and choose manual -> then type your IP - Mask - Gateway - DNS save it

    Service network restart

    now go to wok/kimchi then click visualization -> network you will be able to see the bridge interface

    click on action and start the interface

    点赞 评论 复制链接分享

相关推荐