w15700196641
w15700196641
采纳率0%
2017-07-11 08:29 阅读 6.0k

关于Kettle连接elasticsearch进行数据迁移的问题

5

最近在做数据迁移,有几十亿的数据,想用kettle,但是无论如何不能连接elasticsearch,
elasticsearch为5.新版本的,网上说有一个 15版本的插件可以支持5.x,但是我尝试
很多次后依然不能成功,现在急需帮助,如果有测试成功的,恳请分享一下经验,谢谢了

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

2条回答 默认 最新

  • devmiao devmiao 2017-07-11 16:02
  • m0_37845836 大数据谭志坚 2018-11-26 09:06

    我也遇到这个文档,尝试过各种版本,都是找不到集群, Kettle6, 7,7.1,8.1 都不能连接,使用ES2.2, ES2.3 ,ES.6.3.2, ES6.5.1 等都连接不上。
    kettle本身自带也连接不上ES2.2.

    都是报找不到集群。 而集群是正常的, 我都用程序测试过了,用kibana等都测试过了,还建了索引,写入了数据。

    kettle 在连接ES 方面还是做的不够好啊。 也没得个能用的插件。

    我已经解决这个问题了, 看网址:https://blog.csdn.net/ukakasu/article/details/82351412

    点赞 评论 复制链接分享

相关推荐