weixin_39684960
weixin_39684960
2021-01-07 04:13

Can't run .AppImage on ubuntu 17.10

Version

1.38.2-prusa3d-linux64-full-201711292009.AppImage

Operating system type + version

Ubuntu 17.10

Behavior

When I try to launch the .AppImage from https://github.com/prusa3d/Slic3r/releases, it immediately fails with an error.

$ ~/bin/Slic3r-1.38.2-prusa3d-linux64-full-201711292009.AppImage 
Can't locate object method "GetUserDataDir" via package "Wx::StandardPaths::Get" (perhaps you forgot to load "Wx::StandardPaths::Get"?) at /tmp/.mount_Slic3rlGtkX3/usr/bin/bin/slic3r.pl line 107.

I've tried installing the wx-common and libwx-perl packages, but still encounter the error.

该提问来源于开源项目:prusa3d/PrusaSlicer

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

9条回答

  • weixin_39684960 weixin_39684960 4月前

    I also get the same error when I download the tarball and try to run it that way.

    点赞 评论 复制链接分享
  • weixin_39999190 weixin_39999190 4月前

    Getting the same on macOS.

    
    $ /Applications/Slic3r.app/Contents/MacOS/Slic3r
    Can't locate object method "GetUserDataDir" via package "Wx::StandardPaths::Get" (perhaps you forgot to load "Wx::StandardPaths::Get"?) at /Applications/Slic3r.app/Contents/MacOS/slic3r.pl line 107.
    
    点赞 评论 复制链接分享
  • weixin_39591455 weixin_39591455 4月前

    Oh, good, it's not just me doing something stupid. #4 with same behaviour and same error message.

    点赞 评论 复制链接分享
  • weixin_39819393 weixin_39819393 4月前

    I have the same problem on my Ubuntu 17.10

    morgan:~/opt$ ./Slic3r-1.38.2-prusa3d-linux64-full-201711292009.AppImage Can't locate object method "GetUserDataDir" via package "Wx::StandardPaths::Get" (perhaps you forgot to load "Wx::StandardPaths::Get"?) at /tmp/.mount_Slic3rvhpBss/usr/bin/bin/slic3r.pl line 107. morgan:~/opt$

    点赞 评论 复制链接分享
  • weixin_39826342 weixin_39826342 4月前

    Shame on me, I did not test on other systems than Windows this time, I was in hurry. I will fix it today with a patch release.

    On Thu, Nov 30, 2017 at 8:15 AM, Roman Moravčík wrote:

    I have the same problem on my Ubuntu 17.10

    morgan:~/opt$ ./Slic3r-1.38.2-prusa3d- linux64-full-201711292009.AppImage Can't locate object method "GetUserDataDir" via package "Wx::StandardPaths::Get" (perhaps you forgot to load "Wx::StandardPaths::Get"?) at /tmp/.mount_Slic3rvhpBss/usr/ bin/bin/slic3r.pl line 107. morgan:~/opt$

    — You are receiving this because you are subscribed to this thread. Reply to this email directly, view it on GitHub https://github.com/prusa3d/Slic3r/issues/594#issuecomment-348103009, or mute the thread https://github.com/notifications/unsubscribe-auth/AFj5I_wHNMgl3IZjn_sTaODQ-ke8RVS2ks5s7lYDgaJpZM4Qvn7P .

    点赞 评论 复制链接分享
  • weixin_39826342 weixin_39826342 4月前

    I have fixed that issue with https://github.com/prusa3d/Slic3r/commit/6aff27f3abf6ea895cc458845a31bc436ffa38a8 A new alpha will be released in a day or two.

    点赞 评论 复制链接分享
  • weixin_39826342 weixin_39826342 4月前

    reopened until a release is ready, so this issue is documented.

    点赞 评论 复制链接分享
  • weixin_39826342 weixin_39826342 4月前

    Fixed with Slic3r 1.38.3 beta release.

    点赞 评论 复制链接分享
  • weixin_39623750 weixin_39623750 4月前

    Problem still exists

    点赞 评论 复制链接分享