eclipse导入web项目出错问题?

项目的配置如下:
图片说明
图片说明

eclipse的配置如下:
图片说明
图片说明

9个回答

jdk版本太低 或者 里面 jar包 版本太低。。。。报错 但是不影响代码运行 也可以。我的项目也报错,但是可以正常使用

什么错误,截图看一下

qq_36327827
yuen142 我说的意思是 这个项目一点问题都没有。 从老大那儿拷过来的代码 报错肯定是因为我这边环境的问题 就是不清楚 问题出在哪儿 jdk jre 还是 tomcat 或者其他配置?
2 年多之前 回复

1.换成jdk 1.7试试看
2.忽略一些错误

可是导入的项目 很多报错~~
图片说明

。。。你不具体的错误贴出来啊。。。你这么看,谁知道什么错误啊?

qq_36327827
yuen142 我说的意思是 这个项目一点问题都没有。 从老大那儿拷过来的代码 报错肯定是因为我这边环境的问题 就是不清楚 问题出在哪儿 jdk jre 还是 tomcat 或者其他配置?
2 年多之前 回复

我说的意思是 这个项目一点问题都没有。 从老大那儿拷过来的代码
报错肯定是因为我这边环境的问题
就是不清楚 问题出在哪儿 jdk jre 还是 tomcat 或者其他配置?

qq_36327827
yuen142 呵个蛋蛋, 我说的什么意思都不晓得 呵呵
2 年多之前 回复
qq_28128747
SMART-AI 回复yuen142: 呵呵 good luck !!!
2 年多之前 回复
qq_36327827
yuen142 回复SMART-AI: 没有规定使用版本,只是将项目代码发我让我跑起来。 我这边肯定是IDE环境问题
2 年多之前 回复
qq_28128747
SMART-AI 第二步 基本看了一下 ,你这几个异常 可以忽略, 去windows -project-validtate 忽略报错异常 http://jingyan.baidu.com/article/4f7d5712d3701a1a20192786.html
2 年多之前 回复
qq_28128747
SMART-AI 我没有说你的项目有问题 麻烦看清楚 ok 第一步 检查环境 请确认项目环境是否月你们规定使用版本一致
2 年多之前 回复

报错的都是些参数、 小括号、花括号 无法解析, 原因可以肯定不在代码 是IDE环境问题
图片说明

一般导入错误有以下可能:JDK问题,这种问题在你把鼠标放在错误语句上时会提示你切换jdk版本;另外一种就是项目jar包未导入,查看项目lib目录下jar包是否有导入。
另外,不是我说兄弟,其实你把项目目录截个图问题看起来会舒服很多。

哥们 动动手 把 error 点开 截图 要详细

qq_36327827
yuen142 我说的意思是 这个项目一点问题都没有。 从老大那儿拷过来的代码 报错肯定是因为我这边环境的问题就是不清楚 问题出在哪儿 jdk jre 还是 tomcat 或者其他配置?
2 年多之前 回复
qq_28128747
SMART-AI 也可以忽略这些检查时错误 可以到windows 下面 pre ---》 有validtas 什么的 去 忽略
2 年多之前 回复
qq_28128747
SMART-AI 一般web项目报错 有可能是js错误 也有可能是 包引用错误 就是没有成功引入 libry 这时候 就需要你自己手动改 依赖包
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问