OSPF多进程之间通信的问题

请问怎么在这个拓扑中让PC1和PC2 能够ping通图片

2个回答

进程间路由相互引入
配置如下
R1
[R1]display current-configuration
[V200R003C00]
#
sysname R1
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<08bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 12.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.1.254 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
ospf 1
import-route ospf 2
area 0.0.0.0
network 12.1.1.0 0.0.0.255
#
ospf 2
import-route ospf 1
area 0.0.0.0
network 192.168.1.0 0.0.0.255
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
R2的配置
[R2]display current-configuration
[V200R003C00]
#
sysname R2
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0
8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 12.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 23.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 12.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
R3的 配置
[R3]dis current-configuration
[V200R003C00]
#
sysname R3
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 23.1.1.3 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.2.254 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
ospf 1
import-route ospf 2
area 0.0.0.0
network 23.1.1.0 0.0.0.255
#
ospf 2
import-route ospf 1
area 0.0.0.0
network 192.168.2.0 0.0.0.255
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
[R3]

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
关于ospf中lsa传递的问题
请问,在ospf中,如果选举了dr和bdr,那么DRouter只和dr和bdr互换lsa吗?
多区域OSPF怎么跨区域ping到其他区域的路由器
![图片说明](https://img-ask.csdn.net/upload/201706/19/1497871006_845124.png) 求问老大们 我每个路由器都配置了OSPF了分区域的,但是我的R1只能pingR2,pingR3就不行了 这是为什么
ospf 基于区域的认证和基于链路的认证到底有什么区别?
ospf 基于区域的认证和基于链路的认证到底有什么区别? 比如在此网络中,链路认证和区域认证产生的结果不都是一样的吗? 还是说网络太小无法体现,那要在怎样的网络中才能产生差别。 ![图片说明](https://img-ask.csdn.net/upload/201907/15/1563156437_37473.png)
分析OSPF数据包时有问题
![图片说明](https://img-ask.csdn.net/upload/201505/31/1433036256_51001.png) 获取到数据包后,想要单击列表中的一条信息,想显示具体信息的时候,程序就出现了问题。 如下图 ![图片说明](https://img-ask.csdn.net/upload/201505/31/1433036346_594641.png)
ospf 各区域互通问题?
![图片说明](https://img-ask.csdn.net/upload/201812/17/1545036246_104981.png)
nmap探测ospf协议原理是什么?
nmap探测ospf协议,是发送什么包探测,会得到什么响应~~
OSPF中为什么要给DCE配置时钟频率
OSPF中为什么要给DCE配置时钟频率,范围是多少,它到底起什么作用,一个思科的初学者
如何探测路由器是否运行ospf协议
要探测路由器是否运行ospf协议,要发送什么包?会有什么响应?如何判断?如何用c#编写?
SDN新手,要实现 centralized OSPF, 用POX,不知道从哪里入手好
想实现用Mininet 实现 centralized OSPF。搜了一下,没找到POX可以参考的路由协议。不知道从哪里入手写起。刚刚接触SDN,概念上了解一点儿,还从来没实际操作过。 只知道大概流程,每个节点发一个SLA,向上面的controller汇报自己邻区情况,controller 汇总后得到整个网络topology,然后算最短路径,再告诉OVS把flowtable 建好。 不知道这思路对不对,从哪里着手开始做呢?目前看了一点儿Pox代码,在自学python。 谢谢大家~~
quagga协议包接收问题
quagga有好几个路由协议模块,比如BGP,OSPF等等。如果给quagga发送一个协议包,比如就广播ospf的hello包,那么是由哪个模块进行接收处理呢?是由zebra进行接收然后传给协议模块吗?
OSPF数据包实验分析及报告
命令敲了,数据包也抓了,这是课程设计的题目,报告不会写,不会分析,求解,感谢
关于路由重分布的一些问题
[我的文件](https://pan.baidu.com/s/1qYs7c1e "") [设计要求](https://pan.baidu.com/s/1qY2G1Da "") 我能实现三个部分独立工作,分别用的是rip,static,ospf协议,实在不知道如何相互通信,请大家帮帮忙!!谢谢啦
华为路由器AR3260的网络问题诊断
用display ospf peer brief命令查看邻局信息时,时有时无。 ping 相邻的设备也有频繁丢包 此外,crc错误增长的也不快。
在校大学生求各位大佬,C++socket bind绑定ip地址失败,错误码10038,怎么解决?
#include <winsock2.h> #include <ws2tcpip.h> #include <stdio.h> #include <stdlib.h> #include <iostream> #pragma comment(lib,"WS2_32.lib") #define BUFFER_MAX 2048 #define IP_HDRINCL 2 #define SIO_RCVALL _WSAIOW(IOC_VENDOR,1) using namespace std; int main(){ SOCKET sock; int n_read,proto; int flag = 1; char buffer[BUFFER_MAX]; char LocalName[256]; char *ethhead,*iphead,*tcphead,*udphead,*icmphead,*p; WSADATA WSAData; if(WSAStartup(MAKEWORD(2,2),&WSAData)!=0) { printf("WSAStartup ERROR.\\n"); //如果初始化WSADATA结构得到错误码,则显示出错信息 return -1; } // if(sock = socket(AF_INET, SOCK_RAW, IPPROTO_RAW)<0){ // cout<<"Socket创建失败"<<endl; // exit(0); // } // setsockopt(sock, IPPROTO_IP, IP_HDRINCL, (char*)&flag, sizeof(flag)); //设置 IP 头操作选项 ////////////////////////创建并设置原始套接字 sock = socket(AF_INET, SOCK_RAW, IPPROTO_IP);//启用winsock创建原始套接字,SOCK_RAW 类型表示原始套接字类型混杂模式,也就是接收所有包 setsockopt(sock, IPPROTO_IP, IP_HDRINCL, (char*)&flag, sizeof(flag));//设置原始套接字,设置 IP 头操作选项 ////////////////////////把原始套接字绑定到本地主机网卡上,实现将本地网卡置于混杂模式 if(gethostname((char*)LocalName, sizeof(LocalName)-1)!=0) //获取本地主机IP { printf("获取主机名失败 Error:%d.\\n",WSAGetLastError()); return -1; } gethostname((char*)LocalName, 256);//把本地主机名存放入指定的缓冲区中 hostent *pHost = gethostbyname((char*)LocalName); SOCKADDR_IN addr_in; //获取本地 IP 地址 addr_in.sin_addr = *(in_addr *)pHost->h_addr_list[0]; addr_in.sin_family = AF_INET; addr_in.sin_port = htons(40000); if(bind(sock, (PSOCKADDR)&addr_in, sizeof(addr_in))!=0) //把原始套接字绑定在本地主机网卡上 { printf("绑定失败:%d.\\n",WSAGetLastError()); //绑定失败时显示提示信息 return -1; } //////////////////////////设置原始套接字能够接受所有的数据 DWORD dwValue = 1; if(ioctlsocket(sock, SIO_RCVALL, &dwValue)!=0) { printf("ioctlsocket Error:%d.\\n",WSAGetLastError()); //设置失败时显示提示信息 return -1; } while(true){ int ret = recv(sock,buffer,BUFFER_MAX,0); if(ret>0){ ethhead = buffer; p = ethhead; int n = 0XFF; //链路层前6+6+2个字节为目的MAC 源MAC type // printf("MAC: %.2X:%-02X-%.02X-%.02X-%.02X-%.02X ==> %.2X-%.2X-%.2X-%.2X-%.2X-%.2X-\n",p[6]&n,p[7]&n,p[8]&n,p[9]&n,p[10]&n,p[11]&n, // p[0]&n,p[1]&n,p[2]&n,p[3]&n,p[4]&n,p[5]&n); iphead = ethhead;// + 14; p = iphead + 12; //数据包前14个字节后为20字节的第九个字节为协议,第12-16,17-20个字节为源IP,目的IP printf("IP: %d.%d.%d.%d ==> %d.%d.%d.%d\n",p[0]&0XFF,p[1]&0XFF,p[2]&0XFF,p[3]&0XFF,p[4]&0XFF,p[5]&0XFF,p[6]&0XFF,p[7]&0XFF); short length = (short)(iphead+2)[0]; printf("总长度:%d\n",length); proto = (iphead+9)[0]; p = iphead + 20; printf("Protocol:"); switch(proto){ case 1: printf("ICMP\n");break; case 2: printf("IGMP\n");break; case 4: printf("IP\n");break; case 6: printf("TCP\n");break; case 8: printf("EGP\n");break; case 9: printf("IGP\n");break; case 17: printf("UDP\n");break; case 41: printf("IPv6\n");break; case 50: printf("ESP\n");break; case 89: printf("OSPF\n");break; default: printf("不知道,协议编号是%d,请自己查文档\n",proto);break; } } cout<<endl; Sleep(200); } } ``` ```
关于 ACL 规则中反掩码的问题
![图片说明](https://img-ask.csdn.net/upload/201811/12/1542001022_600585.jpg) ![图片说明](https://img-ask.csdn.net/upload/201811/12/1542001040_511821.jpg) 图上橘黄色划线的部分,反掩码为什么不是0.0.0.255呢? 如果是0.0.0.0 那部应该是精确匹配,是不是什么路由都不会引入ospf域了?
计算机网络路由配置问题
综合应用题 如图所示,是总公司和分公司之间的联网,相应的子网地址、掩码及接口地址已经在图上标出,图中的路由器和交换机都是思科公司的设备, R1为总公司接入路由器,R2为分公司路由器,R1通过专线和ISP路由器相连接。总公司用子网1,分公司用子网2。在总公司的网络中,PC-C、PC-D和PC-E属于工程部,PC-F属于财务部,在交换机SWITCH上配置了基于端口的VLAN。工程部计算机属于VLAN2,财务部计算机属于VLAN3,按要求回答以下问题: (1) 该公司网络使用的是哪一类的IP地址? (2) 设该网络的子网掩码为255.255.224.0,请写出子网1的网络地址。 (3) 双绞线可以分为直通线和交叉线,路由器R2和PC-B相连该使用哪种类型线缆? (4) 假设PC-F连在交换机的端口Fa0/1上,写出将该端口分入相应VLAN的命令。 (5) 路由器R1、R2运行RIP协议,试写出R2上的路由配置的相关命令。 (6) 路由器R1、R2运行OSPF协议,区域号为1,试写出R2上的路由配置的相关命令。(3分) (7) 为了实现公司内网访问Internet,在R1上配置了默认静态路由,请写出该路由的配置命令。 ![图片说明](https://img-ask.csdn.net/upload/201612/10/1481336230_188869.png)
Winpcap中关于过滤规则的问题
我看已有的实例上是允许获取TCP,UDP,ARP协议的数据包,但我不知道他的这个过滤 的规则具体写在哪里。我本人要做的是除了以上协议也允许获取OSPF协议的数据包, 求大神指教,我需要改哪里。具体代码如下: struct bpf_program fcode; bpf_u_int32 NetMask; NetMask=0xffffff; pcap_t *pCap; char strErrorBuf[1025]; //OnButtonFiltersave(); char filter[1024]; strcpy(filter, m_strFilterString.GetBuffer(m_strFilterString.GetLength())); m_strFilterString.ReleaseBuffer(); if( getDevice() != NULL ) { if((pCap=pcap_open_live(getDevice()->name,65536,1,1000,strErrorBuf))==NULL) { return ; } if(pcap_compile(pCap, &fcode, filter, 1, NetMask) < 0) { //fprintf(stderr,"\nError compiling filter: wrong syntax.\n"); AfxMessageBox("编译字符串失败,请确认你的规则编写的正确性,或查看帮助文档中规则的编写规范"); return ; } AfxMessageBox("规则:"+m_strFilterString+"\n测试通过!!!!"); pcap_close(pCap); } else AfxMessageBox("当前没有选持要测试的网卡");
急!!!在线等!!嗅探器点击列表程序出问题
在自己做的嗅探器中点击获取到的信息的其中一条,程序会出现问题。 显示“基础类应用程序已停止工作”(问题应该出在OSPF处) 代码如下: //处理信息并把数据显示到列表中 void CCapturePacketDlg::processPacket(const pcap_pkthdr *pkt_header, const u_char *pkt_data) { struct pcap_pkthdr *pHeader = new pcap_pkthdr; u_char *pData; unsigned char *pPosition = (unsigned char *)pkt_data; long nIndex = 0;//标识当前的数据包位置 long nCount = 0;//标识后来 char strData[20];//标识数据 pHeader->caplen=pkt_header->caplen; pHeader->len=pkt_header->len; pData=new unsigned char[pHeader->len]; memcpy((void *)pData,pkt_data,pHeader->len); m_pktHeaders.Add(pHeader); //这两个都是数组 m_pktDatas.Add(pData); nIndex=m_pktHeaders.GetSize()-1; sprintf(strData,"%07d",nIndex+1); nCount=m_listPacket.InsertItem(nIndex,strData,0); m_lTotalCount++; CFramePacket *pFramePacket = new CFramePacket(pData,14); / CString strStamp; struct tm *ltime; //时间戳 ltime=localtime(&pkt_header->ts.tv_sec); //获取时间 strStamp.Format("%d-%d-%d %d:%d:%d",ltime->tm_year+1900,ltime->tm_mon+1,ltime->tm_mday,ltime->tm_hour,ltime->tm_min,ltime->tm_sec); CString strLength; strLength.Format("%ld",pHeader->len); m_listPacket.SetItemText(nCount,1,strStamp); m_listPacket.SetItemText(nCount,2,pFramePacket->GetMacSrcAddr()); m_listPacket.SetItemText(nCount,3,pFramePacket->GetMacDestAddr()); m_listPacket.SetItemText(nCount,4,strLength); if(pFramePacket->GetType() == 0x0800) { CIPPacket ipPacket(pData+14,pHeader->len-14); m_listPacket.SetItemText(nCount,5,ipPacket.GetProtocol()); //显示协议类型(TCP+TCP+OSPF) m_listPacket.SetItemText(nCount,7,ipPacket.GetSrcIP()); m_listPacket.SetItemText(nCount,8,ipPacket.GetDestIP()); if(ipPacket.GetProtocol() == "UDP") { CUDPPacket *pUDPPacket = new CUDPPacket(ipPacket.GetTData(),ipPacket.GetDataLength()); m_listPacket.SetItemText(nCount,6,pUDPPacket->GetSrcPort()); m_listPacket.SetItemText(nCount,9,pUDPPacket->GetDestPort()); delete pUDPPacket; pUDPPacket = NULL; m_lUdpCount++;//UDP包加1 } else if(ipPacket.GetProtocol() == "TCP") { CTCPPacket *pTCPPacket = new CTCPPacket(ipPacket.GetTData(),ipPacket.GetDataLength()); m_listPacket.SetItemText(nCount,6,pTCPPacket->GetSrcPort()); m_listPacket.SetItemText(nCount,9,pTCPPacket->GetDestPort()); delete pTCPPacket; pTCPPacket = NULL; m_lTcpCount++;//TCP包加1 } else if(ipPacket.GetProtocol() == "OSPF") { COSPFPacket *pOSPFPacket = new COSPFPacket(ipPacket.GetTData(),ipPacket.GetDataLength()); delete pOSPFPacket; pOSPFPacket = NULL; m_lOspfCount++;//OSPF包加1 } } else if(pFramePacket->GetType() == 0x0806) ////如果是ARP数据包 { m_listPacket.SetItemText(nCount,5,"ARP"); CARPPacket *pARPPacket = new CARPPacket(pData+14,pHeader->len-14); m_listPacket.SetItemText(nCount,7,pARPPacket->GetSPAddr()); m_listPacket.SetItemText(nCount,8,pARPPacket->GetDPAddr()); delete pARPPacket; pARPPacket = NULL; m_lArpCount++;//ARP包加1 } else { CString strProtocol; strProtocol.Format("0X%x",pFramePacket->GetType()); m_listPacket.SetItemText(nCount,5,strProtocol); m_lOtherCount++; } delete pFramePacket; pFramePacket = NULL; ShowPacketCount();//显示统计量信息 } //将数据内容显示到协议树上 void CCapturePacketDlg::ShowPacketForTree(const pcap_pkthdr *pkt_header, const u_char *pkt_data,long index) { m_treeSingerPacket.DeleteAllItems(); CString strTitle; strTitle.Format("第%ld个数据包",index+1); //title HTREEITEM hRoot = m_treeSingerPacket.InsertItem(strTitle); //树的根节点句柄 HTREEITEM hSubItem = m_treeSingerPacket.InsertItem("链路层数据",hRoot); //分支的 CFramePacket *pFramePacket = new CFramePacket(pkt_data,14); //再次与链路层打交道,获取链路层信息。 HTREEITEM hItem = m_treeSingerPacket.InsertItem("源MAC地址 : "+pFramePacket->GetMacSrcAddr(),hSubItem); //细化信息 hItem = m_treeSingerPacket.InsertItem("目的MAC地址 : "+pFramePacket->GetMacDestAddr(),hSubItem); CString strType; strType.Format("类型 : 0X%x",pFramePacket->GetType()); hItem = m_treeSingerPacket.InsertItem(strType,hSubItem); if(pFramePacket->GetType() == 0x0800) //当时IP数据报时,显示网络层信息 { hSubItem = m_treeSingerPacket.InsertItem("网络层数据",hRoot); CIPPacket ipPacket(pkt_data+14,pkt_header->len-14); hItem = m_treeSingerPacket.InsertItem("协议 : IP",hSubItem); //应该是按顺序来的 hItem = m_treeSingerPacket.InsertItem("源IP : "+ipPacket.GetSrcIP(),hSubItem); hItem = m_treeSingerPacket.InsertItem("目的IP : "+ipPacket.GetDestIP(),hSubItem); hItem = m_treeSingerPacket.InsertItem("版本号: "+ipPacket.GetVersion(),hSubItem); if(ipPacket.GetProtocol() == "UDP") { CUDPPacket *pUDPPacket = new CUDPPacket(ipPacket.GetTData(),ipPacket.GetDataLength()); hItem = m_treeSingerPacket.InsertItem("协议 : UDP",hSubItem); hItem = m_treeSingerPacket.InsertItem("源端口 : "+pUDPPacket->GetSrcPort(),hSubItem); delete pUDPPacket; pUDPPacket = NULL; } else if(ipPacket.GetProtocol() == "OSPF") //OSPF数据包协议树显示 { COSPFPacket *pOSPFPacket = new COSPFPacket(ipPacket.GetTData(),ipPacket.GetDataLength()); hItem = m_treeSingerPacket.InsertItem("协议 : OSPF",hSubItem); hItem = m_treeSingerPacket.InsertItem("版本 : "+pOSPFPacket->GetVersion(),hSubItem); hItem = m_treeSingerPacket.InsertItem("报文类型 : "+pOSPFPacket->GetPacketType(),hSubItem); hItem = m_treeSingerPacket.InsertItem("报文长度 : "+pOSPFPacket->GetPacketLength(),hSubItem); hItem = m_treeSingerPacket.InsertItem("RouterID : "+pOSPFPacket->GetRouterID(),hSubItem); hItem = m_treeSingerPacket.InsertItem("区域号: "+pOSPFPacket->GetAreaID(),hSubItem); hItem = m_treeSingerPacket.InsertItem("校验和 : "+pOSPFPacket->GetCheckSum(),hSubItem); hItem = m_treeSingerPacket.InsertItem("认证类型 : "+pOSPFPacket->GetAuType(),hSubItem); if(pOSPFPacket->GetPacketType() =="HELLO") //如果OSPF的报文类型为Hello时 { COspfHello *pHelloPacket=new COspfHello(pOSPFPacket->GetHData(),pOSPFPacket->GetDataLength()); hItem = m_treeSingerPacket.InsertItem("子网掩码 : "+pHelloPacket->GetNetMask(),hSubItem); hItem = m_treeSingerPacket.InsertItem("Hello时间 : "+pHelloPacket->GetHelloInterval(),hSubItem); hItem = m_treeSingerPacket.InsertItem("选项: "+pHelloPacket->GetOption(),hSubItem); hItem = m_treeSingerPacket.InsertItem("优先级: "+pHelloPacket->GetPriority(),hSubItem); hItem = m_treeSingerPacket.InsertItem("失效时间: "+pHelloPacket->GetPriority(),hSubItem); hItem = m_treeSingerPacket.InsertItem("DR: "+pHelloPacket->GetDR(),hSubItem); hItem = m_treeSingerPacket.InsertItem("BDR: "+pHelloPacket->GetBDR(),hSubItem); hItem = m_treeSingerPacket.InsertItem("邻居: "+pHelloPacket->GetNeighbor(),hSubItem); delete pHelloPacket; pHelloPacket=NULL; } else { } delete pOSPFPacket; pOSPFPacket = NULL; } m_treeSingerPacket.Expand(hSubItem,TVE_EXPAND); } }
用cisco packet tracer设计一个网络
设计要求: 按照自己设计的内容说明网络的总体设计方案,画出详细的拓扑结构图,并在报告中进行详细描述。 设计内容应至少包括:详细的网络拓扑结构图;详细的IP规划;交换机的配置;VLAN划分;路由器的配置;静态路由设置;动态路由设置;DHCP配置;访问控制列表ACl策略配置(AccessControlList);web服务器配置;DNS服务器配置。设计结果功能分析;心得体会; 互联网中的某一个网络的IP地址采用静态配置,其余网络的IP地址由DHCP服务器分配地址。网络至少包含三个路由器,一个路由器配置态路由,一个路由器用RIP配置路由,一个路由器采用OSPF配置路由。其他路由器自定路由配置方式。
相见恨晚的超实用网站
搞学习 知乎:www.zhihu.com 简答题:http://www.jiandati.com/ 网易公开课:https://open.163.com/ted/ 网易云课堂:https://study.163.com/ 中国大学MOOC:www.icourse163.org 网易云课堂:study.163.com 哔哩哔哩弹幕网:www.bilibili.com 我要自学网:www.51zxw
花了20分钟,给女朋友们写了一个web版群聊程序
参考博客 [1]https://www.byteslounge.com/tutorials/java-ee-html5-websocket-example
爬虫福利二 之 妹子图网MM批量下载
爬虫福利一:27报网MM批量下载    点击 看了本文,相信大家对爬虫一定会产生强烈的兴趣,激励自己去学习爬虫,在这里提前祝:大家学有所成! 目标网站:妹子图网 环境:Python3.x 相关第三方模块:requests、beautifulsoup4 Re:各位在测试时只需要将代码里的变量 path 指定为你当前系统要保存的路径,使用 python xxx.py 或IDE运行即可。
字节跳动视频编解码面经
引言 本文主要是记录一下面试字节跳动的经历。 三四月份投了字节跳动的实习(图形图像岗位),然后hr打电话过来问了一下会不会opengl,c++,shador,当时只会一点c++,其他两个都不会,也就直接被拒了。 七月初内推了字节跳动的提前批,因为内推没有具体的岗位,hr又打电话问要不要考虑一下图形图像岗,我说实习投过这个岗位不合适,不会opengl和shador,然后hr就说秋招更看重基础。我当时
开源一个功能完整的SpringBoot项目框架
福利来了,给大家带来一个福利。 最近想了解一下有关Spring Boot的开源项目,看了很多开源的框架,大多是一些demo或者是一个未成形的项目,基本功能都不完整,尤其是用户权限和菜单方面几乎没有完整的。 想到我之前做的框架,里面通用模块有:用户模块,权限模块,菜单模块,功能模块也齐全了,每一个功能都是完整的。 打算把这个框架分享出来,供大家使用和学习。 为什么用框架? 框架可以学习整体
Java学习的正确打开方式
在博主认为,对于入门级学习java的最佳学习方法莫过于视频+博客+书籍+总结,前三者博主将淋漓尽致地挥毫于这篇博客文章中,至于总结在于个人,实际上越到后面你会发现学习的最好方式就是阅读参考官方文档其次就是国内的书籍,博客次之,这又是一个层次了,这里暂时不提后面再谈。博主将为各位入门java保驾护航,各位只管冲鸭!!!上天是公平的,只要不辜负时间,时间自然不会辜负你。 何谓学习?博主所理解的学习,它
程序员必须掌握的核心算法有哪些?
由于我之前一直强调数据结构以及算法学习的重要性,所以就有一些读者经常问我,数据结构与算法应该要学习到哪个程度呢?,说实话,这个问题我不知道要怎么回答你,主要取决于你想学习到哪些程度,不过针对这个问题,我稍微总结一下我学过的算法知识点,以及我觉得值得学习的算法。这些算法与数据结构的学习大多数是零散的,并没有一本把他们全部覆盖的书籍。下面是我觉得值得学习的一些算法以及数据结构,当然,我也会整理一些看过
Python——画一棵漂亮的樱花树(不同种樱花+玫瑰+圣诞树喔)
最近翻到一篇知乎,上面有不少用Python(大多是turtle库)绘制的树图,感觉很漂亮,我整理了一下,挑了一些我觉得不错的代码分享给大家(这些我都测试过,确实可以生成喔~) one 樱花树 动态生成樱花 效果图(这个是动态的): 实现代码 import turtle as T import random import time # 画樱花的躯干(60,t) def Tree(branch
深深的码丨Java HashMap 透析
HashMap 相关概念 HashTab、HashMap、TreeMap 均以键值对像是存储或操作数据元素。HashTab继承自Dictionary,HashMap、TreeMap继承自AbstractMap,三者均实现Map接口 **HashTab:**同步哈希表,不支持null键或值,因为同步导致性能影响,很少被使用 **HashMap:**应用较多的非同步哈希表,支持null键或值,是键值对...
大学四年自学走来,这些私藏的实用工具/学习网站我贡献出来了
大学四年,看课本是不可能一直看课本的了,对于学习,特别是自学,善于搜索网上的一些资源来辅助,还是非常有必要的,下面我就把这几年私藏的各种资源,网站贡献出来给你们。主要有:电子书搜索、实用工具、在线视频学习网站、非视频学习网站、软件下载、面试/求职必备网站。 注意:文中提到的所有资源,文末我都给你整理好了,你们只管拿去,如果觉得不错,转发、分享就是最大的支持了。 一、电子书搜索 对于大部分程序员...
linux系列之常用运维命令整理笔录
本博客记录工作中需要的linux运维命令,大学时候开始接触linux,会一些基本操作,可是都没有整理起来,加上是做开发,不做运维,有些命令忘记了,所以现在整理成博客,当然vi,文件操作等就不介绍了,慢慢积累一些其它拓展的命令,博客不定时更新 顺便拉下票,我在参加csdn博客之星竞选,欢迎投票支持,每个QQ或者微信每天都可以投5票,扫二维码即可,http://m234140.nofollow.ax.
Python 基础(一):入门必备知识
目录1 标识符2 关键字3 引号4 编码5 输入输出6 缩进7 多行8 注释9 数据类型10 运算符10.1 常用运算符10.2 运算符优先级 1 标识符 标识符是编程时使用的名字,用于给变量、函数、语句块等命名,Python 中标识符由字母、数字、下划线组成,不能以数字开头,区分大小写。 以下划线开头的标识符有特殊含义,单下划线开头的标识符,如:_xxx ,表示不能直接访问的类属性,需通过类提供
程序员接私活怎样防止做完了不给钱?
首先跟大家说明一点,我们做 IT 类的外包开发,是非标品开发,所以很有可能在开发过程中会有这样那样的需求修改,而这种需求修改很容易造成扯皮,进而影响到费用支付,甚至出现做完了项目收不到钱的情况。 那么,怎么保证自己的薪酬安全呢? 我们在开工前,一定要做好一些证据方面的准备(也就是“讨薪”的理论依据),这其中最重要的就是需求文档和验收标准。一定要让需求方提供这两个文档资料作为开发的基础。之后开发
网页实现一个简单的音乐播放器(大佬别看。(⊙﹏⊙))
今天闲着无事,就想写点东西。然后听了下歌,就打算写个播放器。 于是乎用h5 audio的加上js简单的播放器完工了。 欢迎 改进 留言。 演示地点跳到演示地点 html代码如下`&lt;!DOCTYPE html&gt; &lt;html&gt; &lt;head&gt; &lt;title&gt;music&lt;/title&gt; &lt;meta charset="utf-8"&gt
Python十大装B语法
Python 是一种代表简单思想的语言,其语法相对简单,很容易上手。不过,如果就此小视 Python 语法的精妙和深邃,那就大错特错了。本文精心筛选了最能展现 Python 语法之精妙的十个知识点,并附上详细的实例代码。如能在实战中融会贯通、灵活使用,必将使代码更为精炼、高效,同时也会极大提升代码B格,使之看上去更老练,读起来更优雅。 1. for - else 什么?不是 if 和 else 才
数据库优化 - SQL优化
前面一篇文章从实例的角度进行数据库优化,通过配置一些参数让数据库性能达到最优。但是一些“不好”的SQL也会导致数据库查询变慢,影响业务流程。本文从SQL角度进行数据库优化,提升SQL运行效率。 判断问题SQL 判断SQL是否有问题时可以通过两个表象进行判断: 系统级别表象 CPU消耗严重 IO等待严重 页面响应时间过长
2019年11月中国大陆编程语言排行榜
2019年11月2日,我统计了某招聘网站,获得有效程序员招聘数据9万条。针对招聘信息,提取编程语言关键字,并统计如下: 编程语言比例 rank pl_ percentage 1 java 33.62% 2 c/c++ 16.42% 3 c_sharp 12.82% 4 javascript 12.31% 5 python 7.93% 6 go 7.25% 7
通俗易懂地给女朋友讲:线程池的内部原理
餐厅的约会 餐盘在灯光的照耀下格外晶莹洁白,女朋友拿起红酒杯轻轻地抿了一小口,对我说:“经常听你说线程池,到底线程池到底是个什么原理?”我楞了一下,心里想女朋友今天是怎么了,怎么突然问出这么专业的问题,但做为一个专业人士在女朋友面前也不能露怯啊,想了一下便说:“我先给你讲讲我前同事老王的故事吧!” 大龄程序员老王 老王是一个已经北漂十多年的程序员,岁数大了,加班加不动了,升迁也无望,于是拿着手里
经典算法(5)杨辉三角
杨辉三角 是经典算法,这篇博客对它的算法思想进行了讲解,并有完整的代码实现。
腾讯算法面试题:64匹马8个跑道需要多少轮才能选出最快的四匹?
昨天,有网友私信我,说去阿里面试,彻底的被打击到了。问了为什么网上大量使用ThreadLocal的源码都会加上private static?他被难住了,因为他从来都没有考虑过这个问题。无独有偶,今天笔者又发现有网友吐槽了一道腾讯的面试题,我们一起来看看。 腾讯算法面试题:64匹马8个跑道需要多少轮才能选出最快的四匹? 在互联网职场论坛,一名程序员发帖求助到。二面腾讯,其中一个算法题:64匹
面试官:你连RESTful都不知道我怎么敢要你?
面试官:了解RESTful吗? 我:听说过。 面试官:那什么是RESTful? 我:就是用起来很规范,挺好的 面试官:是RESTful挺好的,还是自我感觉挺好的 我:都挺好的。 面试官:… 把门关上。 我:… 要干嘛?先关上再说。 面试官:我说出去把门关上。 我:what ?,夺门而去 文章目录01 前言02 RESTful的来源03 RESTful6大原则1. C-S架构2. 无状态3.统一的接
JDK12 Collectors.teeing 你真的需要了解一下
前言 在 Java 12 里面有个非常好用但在官方 JEP 没有公布的功能,因为它只是 Collector 中的一个小改动,它的作用是 merge 两个 collector 的结果,这句话显得很抽象,老规矩,我们先来看个图(这真是一个不和谐的图????): 管道改造经常会用这个小东西,通常我们叫它「三通」,它的主要作用就是将 downstream1 和 downstre...
为啥国人偏爱Mybatis,而老外喜欢Hibernate/JPA呢?
关于SQL和ORM的争论,永远都不会终止,我也一直在思考这个问题。昨天又跟群里的小伙伴进行了一番讨论,感触还是有一些,于是就有了今天这篇文。 声明:本文不会下关于Mybatis和JPA两个持久层框架哪个更好这样的结论。只是摆事实,讲道理,所以,请各位看官勿喷。 一、事件起因 关于Mybatis和JPA孰优孰劣的问题,争论已经很多年了。一直也没有结论,毕竟每个人的喜好和习惯是大不相同的。我也看
项目中的if else太多了,该怎么重构?
介绍 最近跟着公司的大佬开发了一款IM系统,类似QQ和微信哈,就是聊天软件。我们有一部分业务逻辑是这样的 if (msgType = "文本") { // dosomething } else if(msgType = "图片") { // doshomething } else if(msgType = "视频") { // doshomething } else { // doshom...
致 Python 初学者
欢迎来到“Python进阶”专栏!来到这里的每一位同学,应该大致上学习了很多 Python 的基础知识,正在努力成长的过程中。在此期间,一定遇到了很多的困惑,对未来的学习方向感到迷茫。我非常理解你们所面临的处境。我从2007年开始接触 python 这门编程语言,从2009年开始单一使用 python 应对所有的开发工作,直至今天。回顾自己的学习过程,也曾经遇到过无数的困难,也曾经迷茫过、困惑过。开办这个专栏,正是为了帮助像我当年一样困惑的 Python 初学者走出困境、快速成长。希望我的经验能真正帮到你
“狗屁不通文章生成器”登顶GitHub热榜,分分钟写出万字形式主义大作
一、垃圾文字生成器介绍 最近在浏览GitHub的时候,发现了这样一个骨骼清奇的雷人项目,而且热度还特别高。 项目中文名:狗屁不通文章生成器 项目英文名:BullshitGenerator 根据作者的介绍,他是偶尔需要一些中文文字用于GUI开发时测试文本渲染,因此开发了这个废话生成器。但由于生成的废话实在是太过富于哲理,所以最近已经被小伙伴们给玩坏了。 他的文风可能是这样的: 你发现,...
程序员:我终于知道post和get的区别
是一个老生常谈的话题,然而随着不断的学习,对于以前的认识有很多误区,所以还是需要不断地总结的,学而时习之,不亦说乎
《程序人生》系列-这个程序员只用了20行代码就拿了冠军
你知道的越多,你不知道的越多 点赞再看,养成习惯GitHub上已经开源https://github.com/JavaFamily,有一线大厂面试点脑图,欢迎Star和完善 前言 这一期不算《吊打面试官》系列的,所有没前言我直接开始。 絮叨 本来应该是没有这期的,看过我上期的小伙伴应该是知道的嘛,双十一比较忙嘛,要值班又要去帮忙拍摄年会的视频素材,还得搞个程序员一天的Vlog,还要写BU...
加快推动区块链技术和产业创新发展,2019可信区块链峰会在京召开
11月8日,由中国信息通信研究院、中国通信标准化协会、中国互联网协会、可信区块链推进计划联合主办,科技行者协办的2019可信区块链峰会将在北京悠唐皇冠假日酒店开幕。   区块链技术被认为是继蒸汽机、电力、互联网之后,下一代颠覆性的核心技术。如果说蒸汽机释放了人类的生产力,电力解决了人类基本的生活需求,互联网彻底改变了信息传递的方式,区块链作为构造信任的技术有重要的价值。   1...
程序员把地府后台管理系统做出来了,还有3.0版本!12月7号最新消息:已在开发中有github地址
第一幕:缘起 听说阎王爷要做个生死簿后台管理系统,我们派去了一个程序员…… 996程序员做的梦: 第一场:团队招募 为了应对地府管理危机,阎王打算找“人”开发一套地府后台管理系统,于是就在地府总经办群中发了项目需求。 话说还是中国电信的信号好,地府都是满格,哈哈!!! 经常会有外行朋友问:看某网站做的不错,功能也简单,你帮忙做一下? 而这次,面对这样的需求,这个程序员...
相关热词 c#处理浮点数 c# 生成字母数字随机数 c# 动态曲线 控件 c# oracle 开发 c#选择字体大小的控件 c# usb 批量传输 c#10进制转8进制 c#转base64 c# 科学计算 c#下拉列表获取串口
立即提问