2 laogao01200 laogao01200 于 2017.09.05 13:45 提问

eclipse无法安装Tomcat8.5版本

图片说明

重新安装了个Tomcat然后在eclipse中无法添加8.5的tomcat,求大神告知.

workspace下的org.eclipse.wst.server.core.prefs和org.eclipse.jst.server.tomcat.core.prefs我已经删除还是添加不了Tomcat

原因:

Tomcat版本比较特别,无法与eclipse绑定,选择8.5提示:

The Apache Tomcat installation at this directory is version 8.5.12. A Tomcat 8.0 installation is expected.

解决方案:http://blog.csdn.net/change518/article/details/52577132

http://jingyan.baidu.com/album/48a42057f8dfafa92525044d.html

6个回答

qq_34837917
qq_34837917   2017.09.05 13:50
已采纳

eclipse版本太低,最高支持tomcat8.0,换eclipse

laogao01200
laogao01200 嗯嗯 我eclipse版本太低 4.5.2好像带不起来8.5的tomcat
11 个月之前 回复
Runner__1
Runner__1   Rxr 2017.09.05 13:49
laogao01200
laogao01200 里面的链接打不开
11 个月之前 回复
Sweet__dream
Sweet__dream   2017.09.05 14:08

重装一个能够匹配上tomcat的eclipse

laogao01200
laogao01200   2017.09.05 14:25

Tomcat版本比较特别,无法与eclipse绑定,选择8.5提示:

The Apache Tomcat installation at this directory is version 8.5.12. A Tomcat 8.0 installation is expected.

解决方案:http://blog.csdn.net/change518/article/details/52577132

http://jingyan.baidu.com/album/48a42057f8dfafa92525044d.html

guo_jd
guo_jd   2017.09.05 15:01

相比换eclipse,换个低版本的Tomcat容易一些

sinat_40121952
sinat_40121952   2017.09.06 10:54

版本不匹配,换更高的eclipse

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
eclipse安装Tomcat8.5
转自:http://blog.csdn.net/change518/article/details/52577132 在eclipse中,当使用tomcat版本为8.5时(一个神奇的版本),无法与eclipse绑定,选择8.0或9.0版本都会提示: The Apache Tomcat installation at this directory is version 8.5.5.
Tomcat8.5版本在eclipse中的配置
在去下载Tomcat时,有7 、 8 、 9 ,由于电脑上装的JDK是1.8所以选择了Tomcat8,然后我非常惊喜的发现有一个Tomcat 8.5.20版本? 在网上搜了一下,发现是对8.0版本的部分优化版,于是本着一个有好插件不用白不用的心理装上了这个8.5版本。。。 于是到了在给eclipse配置的时候,突然发现真TM的是个神(智)奇(障)的版本。。。       因为这个神奇
应对eclipse不支持Tomcat8和Tomcat8.5或者更高版本
在一些低版本的eclipse中可能会出现不支持Tomcat8和Tomcat8.5的情况,我目前发现两种解决办法
Eclipse无Server或者Tomcat8.5解决办法
解决办法:Eclipse -> help -> Install New Software -> 在Work with中输入:Oxygen - http://download.eclipse.org/releases/oxygen,注意“Oxygen”是Eclipse版本类型,根据你的版本修改对应红色文字内容。-> Add ->在最后的Web,XML,Java EE and OSGi Enterprise Development 下选择 勾选 JST Server Adapters 和 JST Server
eclipse配置tomcat8.5
在eclipse中,当使用tomcat版本为8.5时(一个神奇的版本),无法与eclipse绑定,选择8.0或9.0版本都会提示: The Apache Tomcat installation at this directory is version 8.5.5.  A Tomcat 8.0 installation is expected. 如下图:
解决eclipse中不能设置tomcat8.5
我尝试在eclipse中设置tomcat8.5时,提示错误: The Apache Tomcat installation at this directory is version 8.5.0. A Tomcat 8.0 installation is expected. 简单设置并解决。
Eclipse配置Tomcat 8.5版本出现的各种问题
在Eclipse配置Tomcat的时候,发生了好多问题首先,我的Eclipse里面特别干净,所以在Windows->Preferences中很多东西都没有,安装了server的,又没有8.0,有了8.0,又不支持8.5,整个过程有些繁琐,所以现在结自己弄的过程,整合一下,方面以后再用吧下列每一个插件安装后均需要重启Eclipse1.Eclipse的Windows->Preference...
解决eclipse mars2中不能设置tomcat8.5
我尝试在eclipse中设置tomcat8.5时,提示错误:The Apache Tomcat installation at this directory is version 8.5.0. A Tomcat 8.0 installation is expected.解决版本:打开tomcat下的catalina.jar文件,具体目录为:/lib/catalina.jar,使用winrar工具打...
Struts2.5+eclipse+tomcat8.5配置
1. 下载struts2.5文件并解压2. 进入struts-2.5.10.1-all\lib3.找到下图中的jar包导入到eclipse的web工程下的WIn-INF下的lib文件夹中 **4. 配置web.xml<?xml version="1.0" encoding="UTF-8"?> <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-
eclipse无法配置tomcat8.5.29版本的问题
之前一直用的是JDK1.7+tomcat7.0+maven3.39作为开发环境,因为要学习springBoot2.0,所以需要更高版本的JDK和tomcat,所以选择了配置tomcat8.5.29版本。但是当我选择aparch tomcat8.0时,然后tomcat安装路径选择D:\apache-tomcat-8.5.29时,出现了错误提示The Apache Tomcat installatio...