java compiler没有1.8

java compiler没有1.8 怎么解决呢,项目每次都打错,感觉很不舒服,我现在用的是jdk1.8,但是project facts 最大只能选择1.7。 哪位大侠知道怎么修改的 ????

3个回答

你说的是 eclipse?图片说明

如果你的 eclipse版本低 可能就没有对应的 编译器了

danee1
danee1 回复卓成俊: 那就是你的 eclipse 的版本低了,下个新版本的eclipse 就行。说白了 就是 你用的那版本eclipse 开发的时候 还没有jdk8呢,人家怎么支持未来出现的产品?
2 年多之前 回复
u011781616
卓成俊 对 就是这里 只有1.7 我在想是在哪里配置的?
2 年多之前 回复

你用的什么编译器,是myeclipse 还是什么?如果是myeclipse 看看是不是你的版本有点低

u011781616
卓成俊 eclipse
2 年多之前 回复

目前没有,1.7就已经够牛逼的了

qq_18602217
qq_18602217 回复卓成俊: 问题解决了吗?
大约 2 年之前 回复
u011781616
卓成俊 但是我的JDK是1.8 所以总是报错,其实项目还是能跑起来,就是看着打杀杀飘红很不舒服
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问