weixin_39620151
2021-01-08 00:47 阅读 25

linux已经安装了php,但是怎样配置php-cgi变量?

启动fis的调试服务器(注意添加 --no-rewrite 参数),如果报错 没有php-cgi环境,请 安装 它,并把php-cgi命令加到系统的环境变量中:

fis server start checking java support : v1.6.0 checking php-cgi support : unsupported php-cgi environment

[NOTIC] launching java server. starting fis-server ... at port [8080]

[NOTIC] browse http://127.0.0.1:8080/

浏览时直接输出php代码了。。。

setTemplateDir($root . '/template'); $smarty->setConfigDir($root . '/config'); $smarty->addPluginsDir($root . '/plugin'); $smarty->setLeftDelimiter('{%'); $smarty->setRightDelimiter('%}'); $smarty->assign(include($root . '/data/index.php')); $smarty->display('page/index.tpl'); ?>

但是在终端可以运行php: ==>php

song==>php -v PHP 5.3.5-1ubuntu7.11 with Suhosin-Patch (cli) (built: Sep 12 2012 18:47:04) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

请问我该如何设置php-cgi?

该提问来源于开源项目:fex-team/fis

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • weixin_39817122 weixin_39817122 2021-01-08 00:47

    http://fouber.github.io/install-php-cgi/

    点赞 评论 复制链接分享
  • weixin_39620151 weixin_39620151 2021-01-08 00:47

    我用apache直接把根目录改到~/.fis-tmp/www,也可以用了~~,不过还是多谢你!

    点赞 评论 复制链接分享
  • weixin_39817122 weixin_39817122 2021-01-08 00:47

    这样确实也可以,fis的server和fis本身并没有强绑定,只是一个方便的调试服务而已。

    另外,php-cgi和php是不同的,php在编译的时候只有加了--enable-fastcgi才会编译出php-cgi,linux默认安装的php是没有加上过这个参数的,所以一般要重新编译php才行

    点赞 评论 复制链接分享
  • weixin_39620151 weixin_39620151 2021-01-08 00:47

    非常感谢!

    点赞 评论 复制链接分享

相关推荐