用eclipse开发android项目,jdk 7的新特性是不是不被支持

我用eclipse开发android项目的话,jdk7+的新特性是不是不被支持,java compile自动为1.6,如果改为
1.8就会出现错误:

Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead. Please use Android Tools > Fix Project Properties.

5个回答

建议用andtoid Studio来做Android相关开发。集成度更高,对各类Android版本的兼容性也好。

如果你是新手的话,建议你使用Android Studio ,毕竟Google 亲儿子,现在Android 开发工程师已经很少使用Eclipse 了。
如果你正在学习Android开发,那么你应该知道,今年5月份,Google 已经宣布Kotlin为Android开发的首选编程语言,那么
使用IDEA也是一种不错的选择。另外如果你对AndroidStudio稍微了解的话,应该知道,AS就是在IDEA的基础上开发而来,
二者同宗同源。
毕竟,java9都快出来了,Android8也慢慢地开始大行其道,如果不是客户定制,建议从新的开始。

eclipse最新版本的对jdk要求必须是jdk1.8以上所以你不要尝试使用更低版本的,全是bug

建议用低版本的eclipse

eclipse开发Android对jdk7是支持的

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!