tomcat9支持的最低版本的jdk是多少?

今天想试一下我们的程序用tomcat9能不能跑起来,但是我们用的jdk还是7,结果尝试了好一会儿都不行,各种环境变量和startup.bat的内容设置都改了还是不行;后来试了一下jdk8,然后tomcat9一下子就跑起来了;上网查了好久众说纷纭,有的说jdk7+tomcat9是不行的,要么把jdk升级,要么把tomcat降级;;还有的说jdk与tomcat就是两个不同的软件,肯定兼容。。。在这里想问问各位,有没有总结下来的,tomcat9支持的最低版本的jdk是多少??

3个回答

必须jdk8或者以上
http://tomcat.apache.org/whichversion.html 官方文档

7或者是7之后的版本

qq_38626413
Jason_Kronl 回复petersell:哈哈,快打他脸
一年多之前 回复
petersell
petersell 误人子弟
大约 2 年之前 回复

Apache Tomcat Version:9.0.x
Supported Java Versions:8 and later

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐